Why 1 UART sources works and not the other.

Ladies and Gents,

So here is the problem I have been working on with my BeagleBone. I took a GPS and attached it to UART1 pins (P9 24,26), set the pin mux, used a python script to read the data and process it… Glorious! Ok, so now time to hook up the rest of my items. I have an accelerometer, magnetometer, a secondary GPS, servo management system.

I have decided to build alot of these sub systems on a Parallax Propeller Microcontroller to handle some of the little things that need to happen. But I need to be able to open a UART channel to the Microcontroller. I have used UART on it before (in fact with the same GPS). However, I can’t get the Bone and the Prop to talk. I have confirmed the UART single coming out of the Prop as 9600 baud using a UART → USB debugging and I checked to read the GPS with the same settings. Both read to my computer just fine. The GPS is read by linux just fine, but using the same pins and UART channel I can’t get the Prop to talk to it.

I have already tried the following solutions/tweaks:

  1. Assuring the same power source is used for all electronics. Prop creates a 5 voltage signal and is sent to the Bone. More then enough amperage and voltage levels have all been double checked.
  2. 3.3v interface betweeen prop and bone
  3. Same baud speed and others have been tried as well
  4. Used different UART ports and then tried UART1 after others failed to know I had a working script.
  5. Double checked my rx-tx and tx-rx lines are hooked up correctly
  6. oscoped both lines to make sure things looked right. They do. Only difference I noted was 2.90 max voltage from the GPS vs. a 3.37 coming from the Prop.

Hi,

Have you checked that the pin muxing is setup correctly?

-Jonas

Jonas,

Thanks for the response. I actually figured out the solution yesterday. It turned out that my python script was reading for the wrong line terminator and that everything was actually coming in fine.

I would have posted earlier, but I just got allowed into the group today.

Thanks again,

Gregg