Why does adding a line to uEnv.txt brick my BBB?

I have a 2G BBB running the latest Debian and I’m following the Adafruit Oled Learning tutorial located here: https://learn.adafruit.com/ssd1306-oled-displays-with-raspberry-pi-and-beaglebone-black/wiring

but adding the line optargs=capemgr.enable_partno=BB-SPIDEV0 to uEnv.txt and rebooting bricks my BBB. When the line is added and I reboot all the leds are lit and I cannot communicate to it. I have to flash the OS to get it working again.


Mike, I think you should set ‘optargs’ argument at the same line off ‘bootargs’.

Here’s an example that I used to disable Hdmi (virtual) cape:

bootargs=console=ttyO0,115200n8 root=/dev/mmcblk0p2 rw rootfstype=ext4 rootwait optargs=quiet capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN \n
uenvcmd=mmc dev ${mmcdev};load mmc ${mmcdev} ${loadaddr} uImage;load mmc ${mmcdev} ${fdtaddr} am335x-boneblack.dtb;bootm ${loadaddr} - ${fdtaddr} \n

I’ve added the ‘\n’ just here, to show where the line ends.

Jerônimo Lopes

Having optargs on the same line as bootargs is not a requirement.

Mike, did you per chance copy paste that optargs line from within Windows ? uEnv.txt does not take kindly to Windows style line breaks.

You were right on William. Cutting and pasting on a Windows machine was the problem.

Thank You sir!

Awesome mike. Glad it’s working now.