why does latest dev branch of OE now build angstrom for BB?

i was just reminded by an e-mailer that i hadn't checked on why the
last attempt i made to build angstrom for the BB with the development
branch of OE failed, but after doing an update on OE a few minutes
ago, it now looks like it builds, so i'm just curious about what might
have changed.

  i've documented the exact steps i use in building angstrom for the
BB on my fedora 11 system here:


the last time i tried this (a few days ago), i tried to "bitbake
base-image", and the tail end of the output was:

NOTE: Running task 1721 of 3361 (ID: 214,
/home/rpjday/oe/openembedded/recipes/glibc/glibc_2.9.bb, do_package)
mmap: Permission denied
NOTE: preparing tree for binary locale generation
NOTE: generating locale es_NI (UTF-8)
NOTE: Task failed: localedef returned an error (command was
qemu-arm -s 1048576 -r 2.6.24 -L
-cpu cortex-a8
--force --old-style --no-archive
--inputfile=/usr/share/i18n/locales/es_NI --charmap=UTF-8 es_NI).
ERROR: TaskFailed event exception, aborting
ERROR: Build of
/home/rpjday/oe/openembedded/recipes/glibc/glibc_2.9.bb do_package

  i *thought* i'd set up everything properly. so just this morning, i
went back, did "git pull", then leaving angstrom-dev in place, just
ran "bitbake base-image" again, and it completed. strange.

  to be methodical, i should remove the angstrom-dev directory and
build from scratch, but can anyone think of why that build from a few
days ago failed, but this morning, it worked? normally, i would have
thought that i'd failed to set the mmap properties properly, but it
doesn't appear that way.

  thoughts? i think i'll start the build from scratch to verify this.


... snip ...

  never mind ... it's early and i haven't had enough coffee yet. i'd
forgotten that i had to resolve a selinux issue related to mmap. i
even documented it on that page. argh.

  i'll still build again from scratch to play it safe, but i'm curious
as to whether others who were trying to do the same thing had to
resolve the same issues i did related to mmap.