Wifi Adapter Recommendations

Does anyone have a recommendation for a wifi adapter that works with Robert Nelson’s Ubuntu images? I have rtl8188cus and mt7601 and I can not get either to work. At this point I would rather just order one that works rather than waste more time trying to fight with either of these two. I have building the kernel working and have tried several times to build a new driver for both of these adapters but the mt7601 will not show up with iwconfig and the rtl8188cus will show up see my access point but will not connect to it. I am editing /etc/network/interfaces to try and get connected to our WEP “protected” network. I have no control over the type of encryption used. I was able to get everything working on Angstrom with connman so I know it is possible.

Sorry if this became a little bit of a rant but I have spent a lot of time trying everything I could google up and now I just want to throw money at the problem.

Netgear on 3.8 RCN Ubuntu BBW

Sent from Yahoo Mail on Android


Robert Nelson has a post on these forums somewhere where he recommends two 802.11N USB devices that were around $10 each. I want to say they’re Atheros, but I dont remember but hold on . . .

For a “mere” 2-3 more $'s you can get a WiFi dongle that’ll work out
of the box without custom non-mainline drivers that do not always

Atheros (atk9) based modules on amazon…

Just search “wifi” in this group, for all the problems with those
‘tiny’ wifi adapters…


I happen to keep important information to me ( from this group )in a text file so . . . the above in italics was from the post I spoke of.

The text file is a REALLY good idea.

I’m going to start one of my own !

building a driver from

for the little one from adafruit seems to be working quite well.  ran since thursday on 3.12.5 kernel without any issues that i could find so far.

It has been quite a few months since I looked at this as well. I remember back then (June?), that I did find some sources to build the driver for the 8192cu, which back then worked quite well. I think I still have the sources sitting on my PC, but it has been awhile since I figured out how to build and install it.

I installed his Debian build, which I really like, but the edimax adapter has dropped a reasonable number of times now. So may try to see if I kept my notes for installing the patched driver, but in the mean time, I ordered one of the tl-wn722n devices which hopefully will arrive tomorrow. Sometimes it is easier to punt.

Heya Kurt,

I have found a long time ago that, if you’re planning on running Linux on hardware, it’s best to buy hardware with Linux in mind. Especially for NIC./ Wifi adapters. The same goes for motherboard ( chipset ), and video adapters as well, but neither of these really apply to this situation.

Anyhow once I had adopted this way of thinking, my problems reduced significantly

I looked at the tl-wn devices, but I am putting this in a Logic Supply case and the dongle would stick out far enough that i worry about it getting damaged. I am compiling 3.13 right now then going to try it again with that to see how life is.

My directions to myself are at sites.google.com/site/bbbhelper if you need it.

https://sites.google.com/bbbhelper <----- 404

doh, bad link BBB Helper

Thanks guys,

Yep the steps, mentioned look familiar. Although back then, I believe I edited the Makefile differently. That is, I turned off windows turned on the Arm… But it looks like I still have the earlier built 8192cu.ko file, so tomorrow will try running with it and see how well it works. If not will try rebuilding from the new instructions.

William, yep I totally agree, which is why I purchased my first edimax when I purchased my first RPI. I did not see any particular one when BBBk was released so though another ones of these would work. WHen I ordered Odroid U2 I ordered one of their adapter and likewise when I purchased an Intel NUC…

Still having fun playing and learning.

Again thanks,

FYI - Looking through me cheat sheet (readme.md) up on my github project, I found where I got the information back in june:
Not sure if it will help anyone, but this was how I did it then.


Note: my notes mention that it was missing a step of:
cd /usr/src/kernel
make scripts

But it looks like the page was updated to include this.

Again thanks

Fwiw, I’m using a TP-Link RL-WN725N (RTL8188EU chipset) with Roberts Debian images. Just worked out-of-the-box with his 3.12 kernels. Is only sending light logging traffic, but have never seen any issues over several weeks of uptime…

Good to know about the RTL8188EU working. I will have to keep an eye out for that one when I order more. I am going to be using 30 setups as DNC servers for CNC machines.

“now I just want to throw money at the problem.”

You can throw it at me instead of at the problem.


Monday, January 6, 2014 12:54:18 PM UTC-8, KurtE wrote:

, I ordered one of the tl-wn722n devices which hopefully will arrive tomorrow. Sometimes it is easier to punt.

Quick update, I have been using this now for 2 days, and no drops and no random messages showing up in debug terminal :slight_smile: