Windows 7 doesn't mount BBB as usb drive after update

Hello all!

I recently received my Beaglebone Black. I followed the getting started guide HERE, installed the drivers. Afterwards I was able to connect to and use cloud9 etc.

I got to the “Update board with latest software” portion and downloaded BBB-eMMC-flasher-2013.06.06.img.xz and flashed the eMMC successfully. I removed the power, ejected the uSD and then connected to the computer via USB and the BBB wouldn’t mount as a USB drive. Fearing the update failed, I tried again with the same image. That failed… so I tried BBB-eMMC-flasher-2013.06.20.img.xz from HERE and flashed again… still no USB drive. I then tried BBB-eMMC-flasher-2013.06.17.img.xz from HERE… still no USB drive. In a last ditch effort I tried (Current Production Image) BBB-eMMC-flasher-2013.05.20.img.xz from HERE… still no USB drive.

It is important to note that I could SSH into all of these installs (not at though), and verified that everything worked… I can see /dev/mmcblk0p1 is mounted at /media/BEAGLEBONE (with my most current flash) and all the files are present.

I searched in device manager and could not see the BBB at all or any unknown or not working hardware. And in computer management/Disk management there isn’t anything present.

I have attempted other computers (WIN7) and multiple USB ports… same issue,

Anyone have any suggestions? I’m sure I am missing something obvious.

Thank you in advance!

Sounds like the board and SW are working OK as indicated in the Linux portion. This sounds like a Windows driver issue of some sort. Not sure exactly where. You indicated out of the box you could connect, but you never said whether it was detected as a USB drive or not,


Thank you for the reply Gerald! Yes, the board would connect as a USB drive before I updated.

I'm going to try to boot an image off of the uSD and see if that helps.

I flashed this SD boot image and still the BBB will not mount as a usb drive as it did when I received it.

Any suggestions?

Did you hold the boot button down when you powered on the board?


Hey Gerald!

No, I followed the instructions on:

Which said:
To force a boot from the microSD card, delete the MLO file in the FAT partition of the eMMC.

I removed the file while ssh’d in, and verified that it booted the different version.

Still no joy!

OK. Those instructions are fine. I wrote them. If you can SSH in, then the HW is working fine.

So I think the issue is on the Windows 7 side. Can you look in Explorer and see if the BeagleBone device shows up at all?


Sure thing! The device doesn’t show up on either of my windows 7 machines.

No new devices appear in my device list, no new drives in computer management and no tell tale hot plug sound of the usb connection either.

I’ll try again soon on a few more windows machines.

Are there any logs or further troubleshooting I can do?

Thanks again for the assistance! I appreciate it!

What I can’t figure out is why it worked once and not after the updates. And the fact that you can SSH in says the USB is working fine as it uses the USB connection for that. I have windows 7 myself.

There is utility that FTDI has that lets you look at all of the USB ports. Try this and see if the USB port shows up. when plugged in and goes away if you remove it.


Thanks, I will try that now!

I should clarify, I’m able to ssh in via the network (cat5) but not via usb.

Ahh, OK. That makes a difference. Try the utility and see if it shows up an d it may be missing the driver or there is something it does not like.


Hey Gerald,

Attached are the screenshots… There were 3 devices connected before attaching the BBB and 3 afterwards…

I’m not sure what to do next!



Sounds like you may have damaged the USB connection then. Might as well do an RMA and get it sent in to be checked. If it tests good, well we can take it from there and see what we can figure out.


Eesh! Ok, but I don’t know how I could have damaged it when all I did was flash the update!

Either way, I’m very excited to get it working again!

Just curious, if the usb is damaged. (which I don’t suspect)

What is the cost for repairs, shipping etc?

I might just buy another board since this one is still usable sans the usb connection.

What is the cost for shipping etc if it isn’t damaged?


You pay shipping to the depot. They pay shipping back. Repairs are free as long as there is no obvious abuse.

Depending on where you live, another board may end up being cheaper, but it is hard to say.


Sweet! Thank you!

Where is the depot?



Dit you remove the sd card when restarting ? My board wouldn’t mount untill i removed it (another empty sd card, not the one i just used to flash te bbb). I didn’t try the ethernet connection though, so maybe it was a different problem…

Is this post ever going to be “done” ?