Wireless Lan on Beagleboard

What is the magic in getting Wireless LAN to work on Beagleboard?

I have tried three different USB WiFi with no success. I the latest OpenEmbedded code base.

  1. Belkin Wireless G - ZyDas - Recognized with no issues
  2. Trednet TEW-424UB - Modified rtl8187_dev.c to load the module.
  3. SparkLan USB Module based on RA-2571 - Modified code to fix kernel panic and dupliation

In all these three cases i am not able to get an IP address using udhcpc. Would appreciate any pointers,

Thanks
santosh

1) Make sure you have the OTG port in host mode (see /etc/default/usb-
gadget)
2) Make sure you have the correct wireless settings in /etc/network/
interfaces (you to set need at least 'wireless-essid', 'wireless-mode'
and 'wireless-key')
3) I had some issues with udhcpcd before, I prefer dhclient (package
dhcp-client). I installed it using opkg by setting the IP address
manually once and copying over /etc/resolv.conf from another machine
on my network, so I had a working connection for ipkg.

You can check if the stick is recognized using iwconfig, if nothing
works it might help to post the dmesg and iwconfig output

----- snip -----

Well, I have a similar problem, but more basic... first of all, I am
just adventuring into the Linux playground (I come from the Windows
world), so many things and much of the terminology are completely new
to me.

That said, I am trying to install Debian Lenny on the BB. The
installer proceeds up to the point where it needs to connect to some
repository to download additional pieces needed to complete the
installation. I thought that using a WiFi <-> USB dongle that could be
possible. I have a selfpowered hub connected to the USB OTG port of
the BB, which I use for the keyboard, and the mouse.

I attached to this hub first a D-Link G-122 dongle, but the installer
told me that in order to use it, an additional non-free module was
neede, named RT73.bin. Then I tried with a Zyxel dongle, and this time
the modules needed were zd1211/zd1211b_ub.

At this point I am a bit stuck, as I don't have a working Linux on the
BB. What I would need is a uImage that has one (or both) of those
modules already built in.

Any suggestions ? Many thanks

Alberto

Balakrishnan,

I recently installed handheld mojo on my BB and setup my usb wifi NIC.

In my case,

1. I boot my BB(the mojo in already installed according to the mojo
installation instruction) with self-powered usb hub hooked up.

2. I connected the usb wifi to to the hub and confirmed that the
chipset was recognized by the kernel. ('dmesg' at the prompt will show
you the result. At the end of the 'dmesg' output, you can see the main
chipset of your usb wifi NIC. If you cannot, that's another long and
wrong stroy.)

3. I checked if the WLAN interface is recognized at the lower level by
typing 'iwconfig' at the prompt. In my case, the usb wifi was
recognized as 'wlan0'

4. Then, you have to tell the card which AP to catch. I typed
'iwconfig wlan0 essid "FreeWorld"'. Here, 'FreeWorld" is the essid of
my AP. At this moment, I turned off all the security options just to
simplify the test environment.

5. Then, I enabled the NIC at the ethernet level by typing 'ifconfig wlan0 up'.

6. At last, 'dhclient' to get the IP address dynamically from the AP.

That's the simplest manual way to setup the wifi NIC on my BB. I did
this right after I finished the mojo installation according to the
installation.

I hope this helps.

Best regards,

Ilkyoung

I would recommend not doing a net-install and fixing wireless later,
when the system is running. I don't know debian that well but I think
it should be possible to do an offline install from a downloaded apt
repository on an mmc partition or something. Many WiFi dongles require
non-distributable firmware in /lib/firmware, so I don't think you'll
have much luck with the Debian installer.

Or you could use a usb to ethernet dongle ofcourse.