WL1835mod not working with latest TI kernel?


I have a wl1835mod cape and am trying to run the latest TI kernel so I can have sleep mode too (4.1.12-ti-rt-r26).

The problem is that the WL1835mod cape no longer works, all I get is:

dmesg | grep wl

[ 4.160681] wlan-en-regulator: disabling
[ 13.628431] wl1271_sdio: probe of mmc1:0001:1 failed with error -16
[ 13.628584] wl1271_sdio: probe of mmc1:0001:2 failed with error -16

…makes sense if it’s looking for a WL1271 and I have a WL1835, but how can I get it to load the correct driver?

My uEnv.txt:


cmdline=coherent pool=1M quiet

Thank you.

Please help use by apt-get'ing previous kernel's till it worksl:

sudo apt-cache search linux-image-4.1 | grep ti


Hopefully this doesn’t turn into a no disk space left - issue

So I tried apt-get install’ing all the way back to 4.1.1-ti-r1, and I still get the same error =/ It must be something else, since I imagine this was tested with kernel 4.1.x at some point.

I get the same issue with the prebuilt image here https://rcn-ee.com/rootfs/2015-10-09/elinux/ubuntu-14.04.3-console-armhf-2015-10-09.tar.xz, so definitely not an issue with the compilation…