Woes rebuilding & booting Angstrom on my beaglebone

Hello,

I've started tinkering with my (A3) beaglebone, which works just fine using
either the supplied SD card, or alternative SD cards using the 'official' images:
* Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.05-beaglebone-2012.05.09.img.xz
* Angstrom-Cloud9-IDE-eglibc-ipk-v2012.04-core-beaglebone-2012.04.09.img.xz
(only the second has anything in /sys/class/pwm/ ...)

But now I want to build my own image, to enable all 6 pwm outputs. So I
bitbake 'cloud9-image' for the beaglebone (as per
<http://beaglebone.cameon.net/home/building-the-demo-image-files>)

The problems so far:

1) Had a problem with libpam (same as
<https://groups.google.com/d/topic/beagleboard/5AWfEH9nT4Y/discussion> I
think), but it solved itself I don't know how;

2) Some files don't download automatically (same as
<https://groups.google.com/d/topic/beagleboard/aMrS06suLOs/discussion>), so I
had to download them into sources/downloads and add the '%.done' file in there
as well;

3) genext2fs fails with a ftruncate() error. I backed out a commit on the
recipe for the SD card, it apparently solved the problem (details posted in
this thread
<https://groups.google.com/d/topic/beagleboard/KHnzw2GR2eo/discussion>).

Now the bitbake creates an image just fine, that I can dump on a SD card.
Except... the beaglebone doesn't seem to boot. I don't get anything on the USB
port (no gadgets are visible), and the ethernet port doesn't get active.

I'm must be doing something wrong, but I can't figure out why... any help
appreciated.

Cordially,