wrong board on the beagle bone browser


I’ve just receive my beagle bone black from the mail. I followed the instruction on the getting started page and installed the latest Stretch IoT image. I manage to get to the step 3 ( Browse to your Beagle) where I did load the web page at beaglebone.local and receive the confirmation that the board is connected. However, the board in the notification is the SeeedStudio BeagleBone Green not the beagle bone black!

Is this normal? Did I screw up the installation?
Thank you all for your help

Search the forms here. they programmed your board with the wrong eeprom
Robert explained how to fix it in a previous posting.

No the board got programmed with teh wrong eeprom, as root run this "one"
line command... then reboot..

dd if=/opt/scripts/device/bone/bbb-eeprom.dump


ps make sure to gnd tp1 (between barrel jack and ethernet)


"tp4" on the black... tp1 is another board..


Hi guys,
The “dd” command did not work for me (even with TP4 grounded). However, Neilh’s technique worked for me:
1- I grounded TP4
2- I connected to the serial port
3- I started the bbb and interrupted the boot process when prompt

4- I verify the version of U-boot with the command “version”, I got:
U-Boot 2018.03-00002-gac9cce7c6a (Apr 05 2018 - 13:07:46 -0500), Build: jenkins-github_Bootloader-Builder-47

5- I executed the 4 flowing command:

run eeprom_dump

run eeprom_blank

run eeprom_bbb_header

run eeprom_dump

6- I restarted the system with the command “reset”

Now the BeagleBone show up as BBB!

Thank you for help!

Robert I tried this and the command does not work to reprogram the eeprom

is that the correct command ?
or should that of= be an if=

The command is correct, dd takes two parameters, on 1 line… Most emailers jumble that command into 2 lines.

hmmm Ran the command with the tp grounded and the board is still saying
its a green
wonder why

That command can be run from the root command prompt correct ?