x11vnc needs to be restarted after every session

I am using x11vnc for VNC on my BBB. It works great except that I have to re-run x11vnc after every session. I have looked around thinking that someone else must have run into this too but no luck. I can use terminal to see that the x11vnc process is still running but I cannot connect to it after a session has closed until I run it again. I have tried using tight VNC, chicken of the VNC with the same results for both. Does anyone have any ideas about what may be going on or know of a possible solution.

Sorry if this is not a good post… I don’t usually ask questions in forums.

Check the x11vnc forever option setting.


Do a search of the forum. I posted a guide on getting it to run forever.

But there is a simpler way. If you read through that thread Kleven posted a simple two step process which I have verified works.

FYI this might work if you just installed the base vnc package and are manually launching the server (found via a googlegroup post, perhaps Wilfredo’s?):
opkg install angstrom-x11vnc-xinit

Dale, that is the post that I am talking about but please note that the credit for it should go to Kleven and not me, as it was his idea that makes it so simple.

Sorry, failed to give credit where credit is due! Thanks Wilfredo…indeed Kleven provided the info.
Here’s the post’s link: https://groups.google.com/d/msg/beagleboard/23jgTUdDyw4/iO2BQR_l0kwJ

Thanks for posting the link. I would have but my phone apparently does not like links. This POS just copies the link that redirects to the group home page and not to specific threads.