1080p/720p USB Cameras

I’m trying to record a USB 1080p 30fps USB webcam but I can’t get much over 10fps at 1080p or 720p. The resolution change from 1920x1080 to 1280x720 does not seem to effect the fps at all.

I’ve tried 2 cameras, a generic winbook 1080p webcam and a very nice Logitech c930e. I am using MJPEG compression. Both work at 30fps in Ubuntu 14.04 with cheese and avconv (libav-tools).

On the BBB I ran top and iotop and they indicated the CPU never got above 10% and the bandwidth writing to disk was <4,000KBps. I got the same low fps when running on the debian 7.5 (2015-03-01) and 7.9 (2015-11-12) releases. I couldn’t get 8.2 (2015-11-12) to boot but I’ll rewrite the SD card and try again if someone thinks it might help.

The kicker is the Logitech c930e worked at 1080p@30fps on the RaspberryPi2, but the cheap generic camera would only run at 1080p@10fps on the RPi2.

Should I be building the UVC drivers from the latest source or something like that? Is there a newer Kernel I should be using? Am I hitting some kind of USB bottleneck?

good luck if you get 800x600@30

I gave up on USB cameras about a year when I read this…


… partially because it was beyond me, but also because it appeared to be moving at a glacial speed. (not being critical - just an observation)

There are other threads in the Google groups about USB cameras on the BBB - which are not favorable.

as always … good luck

DR. Derrek Molloy has a video on setting up a logitec 920(something) camera, and as I recall the camera was also hardware offloading. I seem to recall he did get 30fps, but perhaps not at 720p


One of these videos, but perhaps both are worth watching.