192.168.7.2 is NOT opening or reachable

Yes I am able to SSH into the 192.168.7.2. I am on personal network. Appending port 3000 to url was not opening in browser.

I think I figured out the issue. On opening 192.168.7.2 I was getting this page:
|460.9477124183007x255

On clicking VSCode.html, page won’t load but the port used in URL was 3000.

I was using the latest image from here

Problem was that port 3000 was disabled. It has to be enabled manually(Details)

After running sudo systemctl enable --now bb-code-server, and reloading, I was able to access VSCode.html at port 3000

.

Let me know if this looks all good to move forward. Thank you :slight_smile:

We don’t use VScode so I would be the wrong person to ask. If you can access it from a browser it would mean your board is configured properly. Are you able to use a standalone web browser and and access the board? If that is the case and it works it would have to be a setup/config issue with VScode.

Vscode, can be a resource hog on am335x, I’m torn between out of the box enabled disabled… I need to better setup the base url, with maybe a readme, I’ve also been thinking of enabling the shellinbox package to easily get to command line thru the browser…

Hi, as shown above in the screenshot, 192.168.7.2 lands to the index/ page. But to access VSCode.html, I have to SSH into the board and only then VSCode Editor loads.

If I SSH into the board and run examples/Beagleboard/Black/seqLEDs.py, I see LEDs blinking in sequence, which means it does communicate correctly.

But, there’s no examples for BeagleBone Blue in the examples folder. Also I feel I think I am missing some other common folders(may be that will show me webpage at 192.168.7.2 instead of directory - index/).

Is this a common problem? In some tutorials I saw Cloud9 IDE making it easier to run commands for sensors directly in the terminal. Can I somehow get Cloud9 like IDE too?

Thanks in advance. Attaching my folder content.

Hi, Not sure if I am following everything correctly, but are you suggesting that cloud9 IDE is right now not supported on latest image for BB-Blue?
Thank you :slight_smile:

Cloud9 (the company) was purchased by Amazon in 2016, all external development really stopped shortly after. I forget which version of nodejs, the whole stack started to break.

Regards,

Thanks for the context. Is there any new tutorial out there which will help in say interacting with sensors onboard BeagleBone Blue.

Most sensors are just normal linux drivers…

Thank you, I will try to interact with sensors and use BB-Blue for my project.

Regards,

Do you have a copy of BeagleboneBlack written by D. Malloy. That is the best source for information regarding what you are doing.

1 Like

Thank you, will checkout the book.

Regards

Crikey! This post was first published over 3 years ago and nothing has been done to resolve this. This is NOT the quick start user experience I was expecting.

Surely someone would have either fixed this problem or removed it from the core documentation describing the getting started process.

Depends… Linux, Windows, or Mac? Which board, out of box image, newer image?

Regards,

I’ve literally just opened up my new BeaglePlay box, grabbed the white printed card that’s found inside, typed in the browser “Quick Start Guide — BeagleBoard Documentation” and I’m now blindly following along what’s on that webpage.

It’s not great. TBH.

I at least had a good chuckle when the first thing I’m shown after the “What’s included in the box?” section is the opening sentence “Attaching the antennas can be complicated. This is not the expected BeaglePlay experience and we hope to fix it in the future.”

Really! This must be a first for a quick start guide. Honestly, it’s that bad.

Anyway, I then moved onto the next section “Tethering to PC” where I connected a USB-C cable to my laptop and to my board. Checking my network connections on my LinuxOS laptop (running Ubuntu 22.04) it shows a wired connection was established.

Then I moved onto this next section… “Access VSCode”.

Here the documentation simply says “Once connected, you can browse to [192.168.7.2:3000] to access the VSCode IDE to browse documents and start programming your BeaglePlay!”

And this is where I get the “NOT opening or reachable” message.

Out of interest, I tried [192.168.7.2] in my browser and this DOES open a page, which provides 2 links, one of which is a html page for VS code but that link fails too (it’s trying to open port 3000).

I then found the forum to search for clues… and found this forum post, which offers plenty of interesting insight, none of which is reflected in the official documentation.

1 Like

This was probably my fault when getting the final Release to Manufacturing Image to Seeed for Play production…

Since you have the board up, please run “sudo beagle-version” so i can note what we missed in the production image…

For the Play, it’s highly recommend to grab the xfce flasher ARM64 - Debian 11.x (Bullseye) - Monthly Snapshots - 2023-10-07 (also available on Latest Software Images - BeagleBoard )

Should have a few things fixed for the out of box image… Updated Docs PDF (usb flash drive snapshot of: BeagleBoard Documentation — BeagleBoard Documentation ) drive, VSCode enabled on port 3000, working cc1352 BeagleConnect firmware.

Regards,

Extract…

dogtag:[BeagleBoard.org Debian Bullseye Xfce Image 2023-02-04]
bootloader:[/dev/mmcblk0boot0]:[tiboot3.bin]:[U-Boot SPL 2021.01-gb248392d (Jan 04 2023 - 19:38:45 +0000)]
bootloader:[/dev/mmcblk0]:[/boot/firmware/tiboot3.bin]:[U-Boot SPL 2021.01-gb248 392d (Jan 04 2023 - 19:38:45 +0000)]
bootloader:[/dev/mmcblk0]:[/boot/firmware/tispl.bin]:[U-Boot SPL 2021.01-gb24839 2d (Jan 04 2023 - 19:38:45 +0000)]
bootloader:[/dev/mmcblk0]:[/boot/firmware/u-boot.img]:[U-Boot 2021.01-gb248392d (Jan 04 2023 - 19:38:45 +0000)]
kernel:[5.10.153-ti-arm64-r86]
nodejs:[v12.22.12]

pkg:[bb-u-boot-beagleboneai64]:[2021.10.20221027.1-0~bullseye+20221128]
pkg:[bb-customizations]:[1.20230202.0-0~bullseye+20230202]
pkg:[bb-usb-gadgets]:[1.20230203.1-0~bullseye+20230203]

Not sure if this is helpful, or not, in figuring out why a custom port number is refused. I’m assuming that as the BeaglePlay is connected via USB the IP address is handled through a webUSB API.

I know that within the Chrome browser there are some handy tools you can use to check connected USB devices, as shown here for the BeagleBone USB composite device:

1 Like

Nope, but that would be cool… Just the old fashioned, dhcp server running on board, giving host machine an address (well as long as host machine runs dhclient…)

looks like a (url landing page) patch for 6.3.x: [PATCH v4] usb: gadget: add WebUSB landing page support - Jó Ágila Bitsch

Regards,

2 Likes

Well, I discovered VS Code’s “Remote Development using SSH” tool awhile back. It’s simple to get set up and even cooler than webUSB.

I find it very effective for code development on SBC’s.

Reference: Developing on Remote Machines using SSH and Visual Studio Code

I had no bother getting it set on the BeaglePlay to access the examples:

1 Like

edit: needed to heavily edit this post as I misunderstood a whole lot of how everything works and still learning…no issues connecting to the Access Point, though unable to reach VSCode on the /index page. But everything else seems to be working fine I just misunderstood a lot things. :slight_smile: