is NOT opening or reachable

I’m just getting started with the BBB and i’m trying to go to on board server as mentioned in the Getting started doc.
But the problem is that is not opening or not reachable. While I have interfaced the BBB with mini B cable to laptop(I’m using Ubuntu 18.0.04 in it) and also connected the BBB with ethernet cable to my laptop.

Please suggest the possible cause and how to debug and make it work.


What Image are you using?
cat /etc/dogtag (provided it is a debian image)
or sudo /opt/scripts/tools/version.sh
or uname -a (might help)

How are you powering the board, 5v supply or usb? if usb, is it via a powered hub?
can you also provide the output of ifconfig from the beaglebone black?
Does Nautilus show BEAGLEBONE folder?

I’m running ‘BeagleBoard.org Debian Image 2019-08-03’ and am able to ssh to the beaglebone black on 7.2 and 6.1 from desktop (ubuntu 18.04)

Hi amf,
it’s been a while since I’ve started using BBB. So, I dont know actually how to get started with BBB.

I haven’t installed any image on BBB on my own. I just followed the steps mentioned in Readme of BBB. (I’ve attached the SS for your reference). Do we need to install any image to BBB first?
Don’t the BBB comes with the preinstalled OS (or image)?

kindly guide me through this.


Screenshot from 2020-07-12 23-05-37.png

ssh: connect to host port 22: Connection timed out

this is what i’m getting as error while connecting BBB to

what could be the reason and how can we resolve this issue.


If you have not modified it’s configuration you should ssh to is the P.C. side.of the connection.

When powering the BBB up and connecting the USB cable does the PC play the UP tone?


Pc does play a sound while connecting BBB to pc. And I’ve not changed any configuration of the BBB.


Your using Ubuntu 18.0.04 good, this is what I’m using also. Are you using any firewall software, like ufw, if you are, make sure port 22 is allowed.
Yes, BBB comes with pre-install OS. If your BBB boots without and sdcard, then it is booting form the emmc.

to boot from the sdcard, you have to hold the ‘USER’ button during the boot process. (that is from the time the power is applied, till the leds start flickering)

Do you have a USB-TO-SERIAL converter that can be connected to J1, it may help in debugging the issue.

Can you ping from your lap top?
When you ssh, are you using debian or root?

You do have openssh-server installed on the laptop, right?

What image are you running on the BBB?

Also, are you seeing an “” ip created on your Ubuntu PC?
You can check this using:
ifconfig -a

You can check the ‘dmesg’ out on your PC to see if there are any errors connecting to the BBB.


I’ve enabled the port 22 on my pc and I’m not using sd card for flashing so I don’t think i need to press the s2 button.
And also i don’t have any debugger and i tried pinging the BBB on that address but it shows all the sent packets are lost so i think I’m unable to ping.

Is there any other way to work this out?

Thanks for your help


That is only required if you have a VERY OLD image in the eMMC (like...
Debian Wheezy! aka Debian v7). If the eMMC has been flashed with anything
in the Jessie, Stretch, Buster time-frame it should have a u-boot which
looks for the SD card, and transfers control to the SD card image to
complete booting (it may have a different problem -- in that early images
relied upon the kernel to load device trees, while newer images rely upon
u-boot to load the device trees)..

  I have not used the BBB boot select button for something like three+
years (and the BB AI doesn't even have a boot select button).

The surest is to NOT USE THE USB "network".

  I presume your main computer is connected to some router.

  Run an ethernet cable from the BBB to the same router. Connect a 5V
power supply to the barrel connector on the BBB. (If you must, you might be
able to use a 5V USB phone charger connected to the USB port -- but for
this debugging you do NOT want the USB port connected to the main

  Check the router configuration pages for what IP # it assigned to the
BBB (note: if the router is modern enough, it may do DNS and have assigned
the host name beaglebone.local to the BBB, in which case you can connect
using the host name instead of the router assigned IP #).

So this is the original image that came with the BBB?
Like some one else just mentioned, you may want to use a ethernet cable connected to your router.

Without knowing what image is on the BBB, it’s going to be difficult to trouble shoot this.

I thought you were running Windows.

Can you ping ?

It might show up as a virtual tty or USB port. Running Linux host I have not done.
If your using Windows pull up device manager and look in com/lpt ports and you
should see a new one something like USB Serial port COM4. That’s what you
should connect to.


Can we connect the BBB using ethernet cable to the computers ethernet port?
( It’s because I’m living in hostel and here we have the hostel wifi available)

And can we power the BBB using 5 V charger?

If not, then will it work out on using the flashed sd card as boot? (I’m thinking to buy one(16gb) for this if doesn’t work)


connecting the ethernet to the computer will not provide you with an IP address on the BBB. BBB wants to use dhcp to get an IP, which what happens when connected to the router.

You should be able to ping from the laptop, if you see on the laptop.

Is this your personal laptop or a company laptop? companies tend to secure laptops such that ping and ssh aren’t allowed (My personal experience)
Would recommend getting an sdcard, again if this is a company laptop, it may not help.

Currently I’m working with my personal laptop only. And also i’ve ordered a 16 gb sd card for sure. But meanwhile i was trying to make it work with with preinstalled os in eMMC only.

Is there any way we can update the eMMC OS? So that it may able to connect to or ( this is because somewhere i’ve seen that Linux system uses this ip to connect with BBB).


Can we connect the BBB using ethernet cable to the computers ethernet port?

  You might need a cross-over cable -- though many newer NICs auto-detect
if cross-over is needed and switch internally.

( It's because I'm living in hostel and here we have the hostel wifi

  Unfortunately, at this point you are back to configuring the host
computer for Internet Connection Sharing -- otherwise there is no pass
through from WiFi to the cable (heck, on my computer, in order to even use
the WiFi I have to disable the cable connection -- it gives priority to the
cable, even if there is no "internet" on that line! I have never tried to
enable ICS).

And can we power the BBB using 5 V charger?

  A Beaglebone Black power supply is 5V 2A, a BB AI should probably be a
bit higher -- 5V 2.5-3A. The BBB has a barrel connector so common USB
chargers may not be applicable -- I've not tried a 2A USB charger.

It uses those addresses only for the USB Gadget. If your computer shows
an RNDIS device under network adapters (in device manager) you HAVE the
192.168.7.x connection. If (in a command prompt)

ssh debian@

gives you a prompt for the beaglebone password

I believe Pankaj is using Ubuntu and not Windows.

Pankaj :

I would suggest checking that your Ubuntu system is creating a ipaddress and is not having an issue connecting to the board via ‘dmesg’.


Only way to update the emmc os without a ethernet connection is by using a USB-to-SERIAL adapter, make sure to get the 3.3 volt version.

Not sure if you answered the prior question. does your laptop show and/or when doing ‘ifconfig -a’ from a terminal window?

If it does, I don’t see any reason why you cannot at least ping the BBB at 6.2 or 7.2.