2 BBB do not boot after opkg update and upgrade


I had the same issue with mine. Based on this http://beagleboard.org/latest-images, the image that shipped with my board is the most current image. I didn’t have a serial cable handy so I didn’t check to see if that would shed any light on the matter. I ended up flashing the latest image onto a microSD card and bringing the board back to the stock image.

If possible, down the line, I’d much rather do the opkg upgrade route so perhaps someone else knows what’s going on.


What’s happening is package “kernel-image-3.8.8” refuses to install b/c it overwrites some files from the previous kernel image.

Instead, do this after the upgrade:

opkg --force-overwrite install kernel-image-3.8.8

That should clear it up.

The full process should look like:

opkg update
opkg upgrade
opkg --force-overwrite kernel-image-3.8.8


Finally, I have downloaded the latest release and reboot from the sd card.

But when I tried again to run

opkg update
opkg upgrade

I got the same problem.
I tried your solution, with no results.

The problem was that I had no longer DNS
I tried with the ip number an a manual install of the kernel-image-3.8.8 with no success.

Finally, I edited the

file where the DNS server were. Obviously, in the upgrade process, this file was modified
and only was left.

When I put the proper DNS server, everything was fine

I could the run

opkg update
opkg upgrade

with just a single error

Configuring bonescript.
Job for bonescript.socket failed. See ‘systemctl status bonescript.socket’ and ‘journalctl -xn’ for details.
Collected errors:

  • pkg_run_script: package “bonescript” postinst script returned status 1.
  • opkg_configure: bonescript.postinst returned 1.

I dont know if this is important, but the BBB could properly reboot.


Hmm, I had that DNS problem too, thought it was a fluke in my environment… Guess that’s one more thing to add to the steps!

And I saw that bonescript error too, it all cleared up on the next reboot I believe. I think it was trying to run some “bonescript.socket” service when the main bonescript service already takes care of it or something. Whatever it is, my “opkg upgrade” now does nothing (besides sit & pause for a while before returning to the shell prompt).

I kept seeing that bonescript error until I edited the file /var/lib/opkg/info/bonescript.postinst and removed the start of bonescript.socket.

I just received my board and wanted to make sure it was up to date. I ran through the steps here to update because I found them ahead of time. I ran into the errors because the DNS was changed during the update so I corrected the file and started again. It seemed to go well. I substituted 3.8.10 for the force-overwrite command because that is what looked like it was being installed.

Yes, 3.8.10 had an unfortunate bug that disabled the eMMC, 3.8.11 fixes that.

I didn't complete the boot after a shutdown. It would hang. I downloaded what was marked as "the lastest image" off the site and installed it on a sd card but it boots to 3.8.3 which is older than what came with the board (3.8.6). Is there another link to a complete fresh latest install image available? I will try to do the update again from the sd card but am not sure if it will fail again. Also, what is the correct steps to reflash the emmc from the sd since I have it booted?

(it may be flashing automatically from sd, I see a couple of tar zxf Angstrom processes running and the led's look a little different so I will let it be). Would still like a good image of the shipped software instead of an older version.

Give http://dominion.thruhere.net/koen/angstrom/beaglebone/BBB-eMMC-flasher-2013.05.02.img.xz a try


I just did an ‘opkg update; opkg upgrade’ from stock and I got the same error:

No NAND device found!!!

I noticed the opkg upgrade wasn’t able to finish successfully and I tried to upgrade and update a few times.

I guess I’ll try out:


and report back.