2014-07-16/lxde/bone-debian-7.6-lxde-armhf-2014-07-16-4gb - devicetree not loading

From ID.txt: BeagleBoard.org BeagleBone Debian Image 2014-07-16

I am unable to load “.dtbo” files:

I have installed on 8GB microSDcard, modified the uEnv.txt file to boot from the SDcard.

Hardware: BBB A5
from dmesg:

[ 0.000000] Kernel command line: console=tty0 console=ttyO0,115200n8 capemgr.enable_partno=ADAFRUIT-UART1 root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait quiet init=/lib/systemd/systemd
[ 1.026722] bone-capemgr bone_capemgr.9: enabled_partno part_number ‘ADAFRUIT-UART1’, version ‘N/A’, prio ‘0’
[ 1.026794] bone-capemgr bone_capemgr.9: slot #7: ‘Override Board Name,00A0,Override Manuf,ADAFRUIT-UART1’
[ 1.033025] bone-capemgr bone_capemgr.9: loader: before slot-7 ADAFRUIT-UART1:00A0 (prio 0)
[ 1.033050] bone-capemgr bone_capemgr.9: loader: check slot-7 ADAFRUIT-UART1:00A0 (prio 0)
[ 1.033075] bone-capemgr bone_capemgr.9: loader: after slot-7 ADAFRUIT-UART1:00A0 (prio 0)
[ 1.033101] bone-capemgr bone_capemgr.9: slot #7: Requesting part number/version based 'ADAFRUIT-UART1-00A0.dtbo
[ 1.033128] bone-capemgr bone_capemgr.9: slot #7: Requesting firmware ‘ADAFRUIT-UART1-00A0.dtbo’ for board-name ‘Override Board Name’, version ‘00A0’
[ 1.417574] bone-capemgr bone_capemgr.9: failed to load firmware ‘ADAFRUIT-UART1-00A0.dtbo’
[ 1.426407] bone-capemgr bone_capemgr.9: loader: failed to load slot-7 ADAFRUIT-UART1:00A0 (prio 0)

I tried other .dtbo files that work on Angstrom, with same result.

Any ideas how to fix this?




thanks, works great.

I think this is better than editing the uEnv.txt file.

Thanks for all your good work.