720p on 2.6.29 doesn't work (also in 2.6.28) - revB7

I try to get from ps3fb.c :
        /* 720pf */
        "720pf", 60, 1280, 720, 13481, 220, 70, 19, 6, 80, 5,

and put in modedb.c
        /* 720pf */
        "720pf", 60, 1280, 720, 13481, 220, 70, 19, 6, 80, 5,

of 2.6.29 tmp/work/beagleboard-angstrom-linux-gnueabi/linux-

I can't make it work !!
ip=dhcp console=ttyS2,115200n8 root=/dev/mmcblk0p2 rootwait rw
omapfb.mode=dvi:720pf init=/init omapfb.debug=omapfb.debug=y
omapdss.def_disp=lcd omapdss.debug=y

but I tried so many booargs ...

kernel messages:
modedb fb_find_mode: Trying specified video mode (ignoring refresh
rate) 0x0
name_matches name=720pf
modedb fb_try_mode: Trying mode 720pf 1280x720-24@60
modedb fb_try_mode: Trying mode 720pf 1280x720-24@60
omapfb omapfb: cannot parse default modes

But u-boot can drive 720p to my LCD tv.
So I saw lat u-boot from denx, or other in openembedded.
I can't find 720p timings.
Anybody can give me the solution.

I think that the modedb.c should contain this mode, because is the
best for LCD TV.

Thanks in advance.

Strangely instead:
works with 2.6.29
but is not nice for TVs.

recalcati, I'm fairly sure it is possible. I seem to recall that there
are several posts on 720p on this list and some patches from last aug.
(from mru if I am not mistaken).

So many changes on the kernel from august....
I'll search, but I hope some help on 2.6.28 or better 2.6.29.
Thank you.
I'll do a check in two days.

It is mainly a matter of getting the right values in the right


I haven't tried that out, but at least the hsync value in that mode is
defined as 80, which is higher than early OMAP3s support.

Only late last week I did add support for wider timings in to my tree,
if the OMAP revision is >= ES3.0.


I have revB7 , so it is ES3.0.
But I have downloaded now linux-omap-2.6.29-
r3+gitr90e758af52ba803cba233fabee81176d99589f09 by OE.
and in drivers/video/modedb.c
still 720p not present.
I'm wrong in kernel tree or in its usage?