Activation of CAN1 on 3.19 (Probably a PIN Mux Problem)

Hi there,

I have some problems of activating the CAN1 Bus for my BeagleBoneBlack.
With 3.8.13 I activated the BUS according with the cape_manger and it worked quiet well.

Now I have installed 3.19 and work with dtb-rebuilder.
What I have done so far:
In the file am335x-boneblack.dts I have outcommented those two lines:
#include "am335x-can1.dtsi"
#include "am335x-bone-can1.dtsi"

After make, make install (no errors), reboot modprobe, activation of can1 bus etc… I get 1:1 the same result in ifconfig as in 3.8.13(with the cape_manager).
can0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

But when I look at the pins in /sys/kernel/debug/pinctrl/44e10800.pinmux/pins I get:
pin 96 (44e10980.0) 00000037 pinctrl-single
pin 97 (44e10984.0) 00000037 pinctrl-single

and for /sys/kernel/debug/pinctrl/44e10800.pinmux/pinmux-pins
pin 96 (44e10980.0): (MUX UNCLAIMED) (GPIO UNCLAIMED)
pin 97 (44e10984.0): (MUX UNCLAIMED) (GPIO UNCLAIMED)

In 3.8.13 (where it works) I have those values:
In /sys/kernel/debug/pinctrl/44e10800.pinmux/pins
pin 96 (44e10980) 00000012 pinctrl-single
pin 97 (44e10984) 00000032 pinctrl-single

and for /sys/kernel/debug/pinctrl/44e10800.pinmux/pinmux-pins
pin 96 (44e10980): 481d0000.d_can (GPIO UNCLAIMED) function dcan1_pins_s0 group dcan1_pins_s0
pin 97 (44e10984): 481d0000.d_can (GPIO UNCLAIMED) function dcan1_pins_s0 group dcan1_pins_s0

So it looks like that the MUX has not been set. Anybody a Idea for a solution in the dtb-rebuilder or another idea?

Thanks in advance!!
Best greetings from Austria.


Problem partly solved:
Wrong dtb-rebuilder used…
I used dtb-rebuilder 3.14, but needed 3.19…

Now it works, but another problem appears.
Candump works fine. I get the signals what I send from my PC.
But I can’t transmit any signals via cansend. After pressing Enter: No Error - Nothing happens.
And after the cansend command I even can’t use candump anymore. If have to “restart” the canbus when I want to receive any signals. Funny thing…