Address of DSP?

i try the DSP examples, RingIO, MessageQ are working, but i have
problems with the readwrite example.

Dsplink, CMEM and LPM are installed and loaded.
When i start the example with the DSP address from the DSPlink User
Guide i get the following error:

root@beagleboard:/readwrite# ./readwritegpp readwrite.out 2414804992
1024 2
============= Sample Application : READWRITE

Hi Michael,
    I think you are using the wrong starting address. What version of
the beagleboard are you using? (i.e. how much memory do you have)
Have you changed the memory mapping at all? The 2414* number in your
command line argument points to a location past the 256 Mb of memory
that non XM boards have. In the past I have tried the readwrite code
with ...

2280587264 = 0x87EF0000 works

This worked if you weren't passing too much data. Hope this helps


I'm using Beagleboard Rev. C3.
The memory map is untouched.
I Have tried with the address you have written and I can call the
example without error! Thanks.
How du you calculate 2280587264 from 0x87EF0000?


Ah, its only hex to dec, ok. Thanks :slight_smile: