AI-64 usb interface not found

Hello everyone,

I just started on BBAI 64 and I’m only plugging in USB-C and the board’s USB interface cannot be found.
To start I wanted to enable SPI 1 on the board, so I followed this:

When trying to restart my card, the card stopped responding. So I thought it was an image problem. So I bought an SD card and followed the procedure on the site. However, despite having tested with all the possible images (eMMC flash or not), it is impossible to see the USB interface appear again (thanks to an ipconfig).
It is therefore impossible to access the card in SSH. I also tried to connect via ethernet but without success.

Do you have an idea ?

Thanks in advance,

PS: I’m starting so don’t be too complex in your explanations please

Hi Louis,

Working with device tree overlays is tricky. My machine didn’t boot for several iterations while i was working on this. As soon as I updated to a new kernel via apt update, it broke SPI1 again. As a beginner, I would recommend sticking with SPI0 until the new SPI1 overlay gets merged into the official release.

To get your AI-64 bootable again, I would take the sdcard to another machine and mount the boot partition (i think it is /dev/mmcblk1p2) and get rid of the SPI1 overlay callout in the extlinux.conf.

Also, I would not use the USB-C interface. I use ethernet with an external 4AMP power supply.

Hope this helps.

1 Like

Just read that again. It seems like you may have been working on the internal emmc and not on a sdcard when this problem occurred. If you don’t have anything you need on the emmc, I would probably just reflash it with the latest flasher image.

I don’t do anything on the emmc. Maybe later once I have something stable, I will put it on the emmc.

Maybe some of the other more experienced users can assist with recovery if you need the data on the emmc.


Hello and thank you for your reply,

I don’t have anything to keep on the flash so no problem with that.
However, impossible to flash the board. I followed the getting-started procedure with the EMMC Flasher image but the usb port still does not appear. However, the heartbeat led reappears when an SD with an image is plugged in (which is a good sign), but nothing more.

As indicated in your answer, I tried with an external power supply or with the USB-C, but nothing.

Any idea?

Thanks for your help,

Ok a couple of things.

Are you sure your USB C cable is a data cable ? You can get some that just provide power and obviously beyond powering the board won’t get you a data connection.

Have you got another cable you can try ?

What is the image you are using on the SD card ? Where did you get it.

If using the link from to get an image, it is going to be quite old.

The latest images can be found here

Thank you for your answer,

I know my cable is a data transition cable because it worked before. To be sure I tried with another cable, but nothing new.

I just tried with the last image: bbai64-emmc-flasher-debian-11.6-xfce-arm64-2023-03-10-10gb.img.xz but it does not work either.


Just to make sure, when booting from an sd card.

  1. remove all power
  2. insert sd card and hold down the boot button and keep it pressed
  3. insert power.
  4. wait for lights to start flashing and then safe to let go of the boot button.

Just pressing the reset button won’t do it. You need to remove power as the boot selection is done on power applied.

Assuming you are doing that, then will need to see what the boot log is showing and for that you will need a serial cable connected to the 3 pin UART connector close to the USB C connector.

Without seeing what is going on, it is very hard to say what is wrong.

I’ll order a cable to see what happens and I’ll let you know.

One more idea:

If you do see the cylon sweep pattern when booting the flasher image, it indicates that the flash is working…

  1. Discard USB-C cable (I have never even plugged a USB-C cable into my AI-64)
  2. Connect AI-64 via ethernet to a router with a dhcp server.
  3. Flash the AI-64 (observing cylon pattern)
  4. Wait for cylon pattern to stop with LEDS on (indicates success)
  5. Power off AI-64
  6. Remove flash media
  7. Power on the AI-64 and observe random flashing LEDs that settle down to a heartbeat
  8. Check routers configuration “attached devices” web page to get the IP address it assigned to the AI-64
  9. ssh into AI-64 over ethernet using router assigned IP address

If you haven’t noticed I am anti-USB :slight_smile: I’ve had a lot of bad experiences with it over the years. Maybe USB is better now but, I am old and set in my ways… :grinning:

I set up my router’s dhcp server to always assign the same IP to my AI-64.

Hello everyone and thank you again for your help,

When I put the SD card with the eMMC image flashed, the leds light up for a while (very short) and then the heartbeat cycle of the led takes place.
I turn off the card then remove the card, turn it on again and nothing. No LED lights up, as if the flash of the card did not take place.
I tried with the different versions of the images but still nothing. It is quite frustrating…

It is impossible to connect an ssh link in ethernet connection. Indeed, when I try to connect to it, the login and the password never give me access (login: root znd pwd : root or login : debian and pwd : pwdtmp).

Do you have another idea?

Best regards,

One last idea I have would be to try connecting locally with a monitor, keyboard, and mouse and see if you get past the boot. If that doesn’t work then the serial cable it is.

1 Like

Hello to all,

I’ll keep you posted on the progress of my problem. The problem was (after reading the uart debug ) just a problem of compatibility with the SD card with a sandisk ultra plus my problem is solved.

Thank you for your help,