Angstrom Distro + VLC media player + mplayer + Logitech Quick Cam Pro 9000 problems

Hello everyone
I've been struggling for the last 3 days trying to get VLC media
player, ffmpeg and mplayer to stream from the Logitech Quick Cam Pro
9000 onto the screen and into the file .
I'm using x11-image from Angstrom, however i have added some
additional software to the bitbake recipe to include all the necessary
libraries to run VLC player as well as mplayer and ffmpeg.
The kernel version that im using is
with the corresponding set of modules for it.

Here is the list of what i have included in the bitbake bile:
DESCRIPTION = "Task new-demo-image"

PR = "r0"

inherit task

ECONFIG ?= "e-wm-config-standard e-wm-config-default"

   mplayer omapfbplay \
  vlc \
  ffmpeg \
  libddmpeg \
  mpeg2dec \
  smpeg \

Image built fine however here is the list of things im trying figure

1. When i run mplayer with the following command:
mplayer tv:// -tv driver=v4l2:width=640:height=480:fps=30:device=/dev/
video0 -nosound
it just hangs right after a printout stating camera capabilities.
Also, sometimes i see the following kernel error message on the
console screen:

musb_h_tx_flush_fifo 124: Could not flush host TX fifo: csr: 000a
musb_h_ep0_irq 1108: no URB for end 0
3:3:1: cannot set freq 16000 to ep 0x86

2. I tried to run VLC couple of times and for some reason it was
constantly crashing the board (sorry, lost the log of this, if it will
do it again i will for sure save it)
However, suddenly it started to work in capture mode displaying the
stream from the camera on the screen. It hasn't crashed since.
However, when i try to stream both to the file and to the screen, the
file gets created but nothing gets written to it. I checked the user
permissions and they are fine.

3. I also tried to use ffmpeg with the following command line:
ffmpeg -y -f video4linux2 -s qcif -r 5 -i /dev/video4 -vcodec mpeg4 -f
mp4 /media/ram/out1.mp4
No luck either, i always get the same error as in case 1.

Any ideas how to get streaming working on Angstrom or maybe im missing

Thanx a lot in advance