Angstrom Enlightenment vs USB?

After using Robert's 2.6.29 image (thx again!) I get consistent GUI
startup, bringing me to the login screen -- but it doesn't see my USB
mouse or keyboard -- at all.

The deuce of it is, it *used* to work -- could there be some setup
file that could have gone bogus, or that I could delete to start over
(other than starting from a fresh SD card)?

I checked the suggestion that it might be my (DLink, active) USB hub
by plugging a card reader into it. Angstrom (from the root login over
the UART) does indeed see and read the card (as sda1) through the hub,
as this brief log shows as I write and read data from /media/sda1/ :

root@beagleboard:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 1.8G 369.5M 1.3G 22% /
tmpfs 40.0K 0 40.0K 0% /mnt/.psplash
none 117.1M 88.0K 117.0M 0% /dev
tmpfs 117.1M 16.0K 117.1M 0% /var/volatile
tmpfs 117.1M 0 117.1M 0% /dev/shm
tmpfs 117.1M 0 117.1M 0% /media/ram
/dev/mmcblk0p2 1.8G 369.5M 1.3G 22% /media/
/dev/mmcblk0p1 46.3M 5.6M 40.7M 12% /media/
/dev/sda1 1.9G 0 1.9G 0% /media/sda1
root@beagleboard:~# cat > /media/sda1/junk
la la la
hi there

root@beagleboard:~# ls -l /media/sda1/junk
-rwxr-xr-x 1 root root 18 May 7 02:47 /media/sda1/junk
root@beagleboard:~# cat /media/sda1/junk
la la la
hi there

Enlightenment bug? Wacky BB? EHCI failure for Rev C2? Anyone have any


They are not listed with lsusb? Also not if you unplug/replug?
If they are listed, do they work with a regular shell?

I also have problems with kbd and 2.6.29 (but my mouse worked).
And the EHCI driver still needs some work.
You might also try to connect them to the OTG port (assuming you have
the proper cable).
Haven't tried that myself.


Yes, they do appear in lsusb

So now it is working! Though it was by going "the long way 'round."

I simply reformated my entire SD card, with two differences:

1. Instead of the demo "uImage" I used to one from Robert's site: that
sudo wget
sudo mv CC-beagle-v2.6.29-58cf2f1-oer31.1 uImage

as he described on

2. instead of the angstrom demo image I made a new image using

so the USB is working again, so far so good, including a hot-plugin of
the keyboard! :slight_smile:

If you use narcissus, you should copy the uImage that's in /boot to the fat partition, otherwise you'll get troubles with kernel modules.



ah... thx -- I saw that go past in teh unpack and wondered....

still it's working just now! :slight_smile:

I'll do that next, thanks again.


So does anyone know why the EHCI is still unstable? (or even whether the
problems being reported are a hardware or driver issue?). Any hints as to
how to go about debugging it?