Angstrom on SD card problem


I just got my new beagleboard rev.c4 this week. To start with, I
checked if the boards were working and connected it to the serial
port. I had problems trying to communicate with minicom. I finally
gave up and used hyperterminal instead. It worked on my first try!

Now that I'm sure nothing is wrong with the boards, I proceeded to
formatting the SD card. I followed several documentation/tutorial
(including the video demo from Digikey) in formatting the SD card. I
can't seem to format the SD properly using the partition editor from
ubuntu. I was able to finally format and make the two partitions
automount using I got from:

Now, I'm installing the Angstrom into the SD card. I still haven't
found any guide that would help me install Angstrom. Everytime I untar
the Angstrom Demo I always get an error; Cannot open: No such file or

I've been working two days now and still no progress. Any help would
be appreciated! Thanks!

Going back a while someone asked pretty much the same question. I
recommended using gtkterm instead of minicom and that worked for him.
You just have to configure the port (ttyS?/ttyUSB?) and you are attached.
I've used gtkterm here since it first appeared some years ago.

I'll stick with hyperterminal at this point. I have some additional
question regarding the SD card formatting.

I found some guides stating to copy MLO, u-boot.bin, & uImage on the
FAT32 partition and untar the Angstrom Demo image on the ext3

Other guides would tell you to include x-load.bin.ift on the FAT 32
partition and modules-2.6.xx-rxx-beagleboard.tgz on the partition on
the ext3 partition.

Which guide will I follow? I have the latest revision C4 beagle.

Also in the
website, several uImage files can be downloaded as shown below:
Which file will I download and copy to the first partition?

Thanks in advance!

BTW, I was able to boot with my SD card but encountered a Kernel panic

I'd recommend IVT VT220 Freeware, I've been using it with my beagle
for months now (with Vista x64 and a 16550 port).
I had been using TeraTerm before that with some success, but IVT's
emulation appears more complete.

I finally got Angstrom running in the beagleboard. But is there a way
I could run Angstrom directly from the SD card (not using a serial
connection and hyperterminal)? Everytime I am able to run Angstrom, I
have to go to hyperterminal and type 'boot" or 'run bootcmd' to
successfully load the OS. If I use & hold the user button while
resetting I get a kernel panic error. Thanks in advance!


Here is what I did and it worked for me. After making partitions in SD
card and loading the u-boot files and ext3 files onto SD card (I used
this link for writing FAT32 files alone:,
I powered on beagleboard with the DVI cable already plugged in. After
powering the board, and holding down USR button with RESET button just
pressed and released, Angstrom booted directly onto DVI

I did not serial port mechanism at all as I am awaiting the arrival of
serial cables.........Just tried after setting up the SD card with
direct booting onto DVI monitor, it worked..........

~Ramasamy Gopalan.

Hi ramasamygopalan,

Thanks for your suggestion. But after reading the link I found this
line quite confusing:

Copy the file that starts uImage… to uImage.bin on the FAT32 boot partition. Recent versions of u-boot.bin expect the kernel binary to >be called uImage, not uImage.bin, so check the output from the bootloader on the serial console if the BeagleBoard does not boot.>

sudo cp uImage.bin /mnt/bootbeagle/uImage.bin

What does the command mean? Or is there a typo error on that code?
Should it be..

sudo cp uImage-2.6.29-r37-beagleboard.bin /mnt/bootbeagle/uImage.bin

I'm interested to know what you did. Thank you!


I gave """"sudo cp uImage /mnt/bootbeagle/uImage""""" as the

I got it working now!

I changed mmcinit to mmc init.

setenv bootcmd 'mmc init;fatload mmc 0 80300000 uImage;bootm 80300000'

That implies you overwrote the default environment at some point, which you shouldn't.



You're right! I was overwhelmed with the number of documentations/
guides I got from different sources. I'm new to beagleboard, so I
tried to follow guides line by line. I must have messed it up with
some bootargs commands.

Any straightforward ideas how I could restore the factory settings?

To reset the uboot environment to the default: nand erase 260000 20000

That will make it use the environment builtin to uboot.



or use the u-boot command resetenv