Angstrom : USB to Serial Missing every other Incoming Character

I’ve attached my BBone to a modem dev platform using two methods.

  1. USB (Modem) to USB (BBone) FTDI Solution
  2. RS232(Modem) to USBtoSerial(BBone) Prolific PL2303 Solution

Drivers for both have been installed via opkg, and both give the same
reusults, all characters are transmitted from the BBone, but only about 50% of
the characters returned are recived by the application. (See attached)

To date, I’ve tried to use ps to locate another application that might be
using my /dev/ttyUSBx port, but without success (See below)

root@beaglebone:~/tcp_serial_redirect# ps | grep
tty 238 root 1952 S /sbin/agetty tty1 38400
269 root 1772 S grep tty

root@beaglebone:~/tcp_serial_redirect# ps | grep
usb 16 root 0 SW< [musb-hdrc.0]
17 root 0 SW< [musb-hdrc.1]
271 root 1772 S grep usb

I was hoping that fuser might be of service, but has been fruitless thus
far. Hardware flow control is turned on in the modem, but since they modem
platform works well under the same circumstances with my Ubuntu 10.04 host
machine, I haven’t changed anything there.

Any thoughts?




I would try killing getty using top and parameter 15 (so it doesn’t respawn) just to see if that helps.

I did a kill of agetty using both parameters 15, and then 9. Both times, it automatically re spawned.

the file system on my card went bad yesterday, had to reformat and reinstall Angstrom and now I’m encountering the same issue, don’t know why that worked before

See my duplicate post in the beaglebone group linked below where I updated status on this issue.

My issue went away by utilizing python as my emulator instead of minicom. Somewhere in the string of terminal emulators, my CR was getting lost I think. When using pyserials, the comms work flawlessly.

Hi Remo, thanks for the post. I had python installed but not the tools module, so that is as far as I got with that. Turns out my issue was with getty interfering, commenting the respawn line in inittab and then restarting the init process (telinit q) got me going.