Hi, I tried to install webmin on my beaglebone black. I am runing debian 8.0 (I tried also on other versions, also ubuntu, but none works)

I have problems with apt-show-versions.

here is error:

Setting up apt-show-versions (0.22.3) …
** initializing cache. This may take a while **
Error: No information about packages! (Maybe no deb entries?)
dpkg: error processing package apt-show-versions (–configure):
subprocess installed post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of webmin:
webmin depends on apt-show-versions; however:
Package apt-show-versions is not configured yet.

dpkg: error processing package webmin (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:

I tried remove apt-show-versions and reinstall and same error. How can I solve this error?

Is there any other alternative for webmin for beaglebone black, tha works.

Any help welcome.

regards, Ales



Then run:

sudo apt-get update

(kiss 200-ish MB goodbye)

sudo apt-get -f install


Reference bug:


apt-show-versions doesn't work when " Acquire::GzipIndexes "true";" is set


thanks. It worked.

Regards, Ales

I had the same problem. Thank you Robert !! :slight_smile:

For reference I have used Beagle Bone Black rev. B with BBB-eMMC-flasher-debian-7.9-console-armhf-2015-11-03-2gb.img.xz image. I recommend this image as it does not contain all the stock-crap (like apache server, GUI and many more).
I was installing webmin 1.78.

Thanks again, bye.

W dniu wtorek, 24 czerwca 2014 20:55:30 UTC+2 użytkownik RobertCNelson napisał:

2 years later I id run into the same error. The solution offered still works !



I’m trying to install webmin on Jessie on BBB and getting this same error, but removing apt-show-versions isn’t working.
Any other ideas?

Removing /etc/apt/apt.conf.d/02compress-indexes didn’t work for me (not sure why). But I got webmin 1.801 installed on Jessie by doing:

apt-get purge apt-show-versions
rm /var/lib/apt/lists/*gz
apt-get -o Acquire::GzipIndexes=false update
apt-get install apt-show-versions
dpkg -i webmin_1.801_all.deb

Hope this helps any other poor souls out there.

Hi dude!

Thanks for your post. Saved my life :)!

I made a post at ServerFault in order to spread the solution.

Thanks once again.

Best Regards,
Ivan Leon

Webmin install complete. You can now login

Thx!! You saved my time!! :slight_smile:

2016년 6월 22일 수요일 오후 11시 4분 13초 UTC+9, bucks...@gmail.com 님의 말:

Thanks for the help. The base issue appears to be that compressed packages (.lz4) do not work at this time. Replacing them with uncompressed packages works. Check in rm /var/lib/apt/lists to see if the packages are .gz or .lz4. Remove them in either case and follow the instructions to finish the job. Very satisfying now that it works.

2019: apt-get -o Acquire::GzipIndexes=false update still works around this … good solution.

Hi All,

I am still getting this error when installing apt-show-verisons:

Error: No information about packages! (Maybe no deb entries?)
dpkg: error processing package apt-show-versions (–configure):
installed apt-show-versions package post-installation script subprocess returne
d error exit status 255
Processing triggers for man-db (2.8.5-2) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried all the solutions mentioned above but its still not working.

Thank you

Hi sam,

Just followed RobertCNelsons instructions from 6/24/14 and the install worked.
Debian Image 2019-08-03 is what I’m working with.

For some reason I keep getting the same error. Now I followed this guide on installing it from tar file and it worked.


Thank you

To get package info for an installed package use

sudo apt show

If you get lines containing “N: Unable to locate package” then that package was not installed.

If the package was installed from a tar file it might not show in sudo apt show.

Hope this helps.