arecord command not found

Hi all,

I installed in my C4 version of BB, my own built Angstrom kernel using
OE. It is 2.6.29 kernel. After loading the kernel, I set out to
perform the kernel based audio in test. When I type "arecord ....."
command, it says "-sh: arecord command not found"....I tried to look
up similar posts in the Beagleboard group, but could not get a
concrete answer......

I request someone to help me out please........

Ramasamy Gopalan.

I am not familiar with this, but in general if that program is a part of the distribution, then maybe there is an issue with the path. Since you say you built your own kernel, did you also build all the applications and other related modules (so you get arecord)? If you did build it, locate the executable using the find command and run it. If you are using busybox, I doubt if this will come up by default.

Anyway, you can wait for answers from the gurus.

Have fun,


I decided to build my own because I had the same problem even when i
used pre-built angstrom image from

Ramasamy Gopalan.

I ve searched for new intel atom pcs and they include box + lcd + board all includes with full working laptop costs ~250$ like but i dont know for unit costs of beagleboard.

150$ for single card is expensive , how effects mass buying of products ?
I've seen more cheaper cards for industrial applications.

Beagleboard is only kit or we can buy mass with cheaper costs ?
Sorry for my english.

We need cheap solution board for industry like beagleboard.
But if buying mass doesnt effect cost of product makes this product useless really against other solutions.


Please respond........I am waiting for inputs from you........

We do not sell Beagle in any quantity at any price for use in a product of any kind. This is not what Beagle is intended to be.

If you want to take the open source information provided and turn it into you own product and build it, you are certainly free to do so.


So is there any commercial solution that i ve completed my project on beagleboard.
We need cheap & good as beagleboard solution for industry ?

are you looking for a commercial OMAP3530 based netbook?

Not netbook , i need board like beagleboard has.
I ve just given netbook as a sample of prices low.

and yes , its for omap3530 board we want.
Commercial and cheap same things have.

Maybe, look at Palm Pre. It sells for $149 from Sprint and uses a 3530 and has lot of useful peripherals. All you need is to figure out how to load your own BL and OS onto it.
Ok, jokes apart, I seriously doubt if you can get a dev board as feature rich as Beagle for that price. You were comparing it with commercial products like netbooks that are mass produced and hence cost less. If you intend to purchase in bulk, you might have to approach an oem.

Kerim BASOL wrote:

and yes , its for omap3530 board we want.
Commercial and cheap same things have.

there is a lot of omap3530 based "industrial" boards,
like e.g. the overo....

Did you look here?


[Kerim, please do not highjack threads and Ramasamy, please answer to
the correct posts.]

Please respond........I am waiting for inputs from you........

As in your original message,

"-sh: arecord command not found"

means, that `arecord` is not installed on your system or not in your

I suspect the former. `arecord` is a utility provided by the ALSA
project [1]. Please make sure you have it installed. I do not see an
extra package for it on [2], but `alsa-utils-aplay` [3] seems to include
it too (»play (and record) sound files via ALSA«) so please verify if it
is installed on your system and if not install it using `opkg`.




overo is same price as beagleboard there is no mass buy product for omap boards ?
does someone have idea about , devkit8000 ? it can be mass buy ?

I would ask them.


hi kerim,

as indicated by gerald, you can check out the technexion products.
i enquired about stock availability and they said they have in stock.


Hi Paul,

Thanks a lot for your pointers. I downloaded the link [3] that you
provided for armv7 architecture, put it in SD card, then installed
using opkg command on the beagle serial console, and it worked
perfectly........But during installation it threw an error that for
installing this utility, it needed libgcc 4.3.3 or greater and I
downloaded that too from the repository and opkg-ed
it.........Initially only aplay command worked, but arecord did
not.......I referred to the thread
and that also got solved.......

Now I am able to record and play it back perfectly.........

Ramasamy Gopalan.

overo is same price as beagleboard there is no mass buy product for omap boards ?
does someone have idea about , devkit8000 ? it can be mass buy ?

What do you mean by mass buy? I am certain gumstix would love to talk with you.


I can play audio, but if I play recorded audio, it is static noise. I
looked at audio
file. It seems recorded but one of two bytes is always either 0xFF or