Audio Cape Rev B1

I’m looking for some help getting the audio cape rev. B1 running on debian. I’m not able to load the overlay, I suspect I’m using the wrong kernel or need to compile the firmware into the kernel.

Circuitco provided an overlay, I have the latest image I can find, BBB-eMMC-flasher-debian-7.4-2014-04-23-2gb.img

I downloaded the overlay here:

From above link:
“The device tree overlay is available at the bottom of this page. … The current Debian images have the required patches and will play audio normally.”

I compiled the overlay on the board with this command

#dtc -o dtb -o BB-BONE-AUDI-02-00A0.dtbo -b 0 -@ BB-BONE-AUDI-02-00A0.dts
and put it in /lib/firmware

root@beaglebone:~# echo BB-BONE-AUDI-02 > /sys/devices/bone_capemgr*/slots

-bash: echo: write error: Invalid argument

dmesg output:

[ 290.610210] bone-capemgr bone_capemgr.9: part_number ‘BB-BONE-AUDI-02’, version ‘N/A’
[ 290.612723] bone-capemgr bone_capemgr.9: slot #7: generic override
[ 290.612784] bone-capemgr bone_capemgr.9: bone: Using override eeprom data at slot 7
[ 290.612836] bone-capemgr bone_capemgr.9: slot #7: ‘Override Board Name,00A0,Override Manuf,BB-BONE-AUDI-02’
[ 290.613099] bone-capemgr bone_capemgr.9: slot #7: Requesting part number/version based 'BB-BONE-AUDI-02-00A0.dtbo
[ 290.613153] bone-capemgr bone_capemgr.9: slot #7: Requesting firmware ‘BB-BONE-AUDI-02-00A0.dtbo’ for board-name ‘Override Board Name’, version ‘00A0’
[ 290.617371] bone-capemgr bone_capemgr.9: slot #7: dtbo ‘BB-BONE-AUDI-02-00A0.dtbo’ loaded; converting to live tree
[ 290.617415] Invalid device tree blob header
[ 290.622050] bone-capemgr bone_capemgr.9: slot #7: Failed to unflatten

I tried to disable HDMI but that didn’t help.

This blog post mentions a possible bug that makes it necessary compile a kernel or change a setting to get loadable overlays. Is that the case here?



Odd, i missed that one..

This should fix it going forward.


info on this can be found here:

the wiki page will be updated shortly with more details…


Thanks, I built and tested it and working fine.


Thanks for the link, I quickly wrote down the steps I took to get the cape working on my blog in case it’s useful to anyone else.

I haven’t tried to dynamically load the overlay again, but that isn’t necessary for what I’m doing.

Best regards,