Bad advice on Libero tools install

The notes make a point of not installing Libero to /usr/local/Microchip/Libero_SoC_v2022.3 but to a non root directory such as ~/microchip. I used ~/opt/microchip.

What the note does not mention is that the license Deamon expects to find the license file at /usr/local/flexlm/licenses. That fact is completely hidden and not mentioned anywhere. Fortunately, running lmgrd generates an error message that gives the fact away.

The second frustration is that the following the very last note in the install process is

git clone https://github.com/vauban353/Microchip-FPGA-Tools-Setup.git

I was unable to make this work. May I suggest that this, no doubt very resource, be made more accessible.

As a general note, having to use Ubuntu 20.04 which is very much out of date is a royal pain!
I tried 23.04, 22.04 very time consuming and a complete waste of time. Don’t do it!!

Finally, I accepted the reality of Ubuntu 20.04 and installed it. In total, I’ve spent a total of three solid days to get to what appears to be a working system. I wonder what challenges are ahead.

1 Like

Hello,

Did you make it work? git.beagleboard.org has the latest Microchip-FPGA-Tools-Setup.git repo.

Also, you can change that script to make things work from w/in the file: setup-microchip-tools.sh

It is not forbidden. Also, the correct gitlab setup can be found here: BeagleV-Fire / Microchip FPGA Tools Setup · GitLab (beagleboard.org)

Also, the license can be altered too in location of itself. /microchip/license/license.dat or whatever location.

Seth

P.S. The one thing I messed up during he install was forgetting the . before ./setup-microchip-tools.sh to make it look like this idea: . ./setup-microchip-tools.sh

Oh! I am using the 22.04.3 versioning of Ubuntu! It needs to be set up correctly but it works…

A license like this:\

Looks like they are now all about selling subscriptions and not chips. Years ago we used several of their products and they did have the best tools. However if memory (long time ago) is correct the tools even for commerical use were free since you need good tools to build products with their silicon.

In most cases you don’t need the “Gold” license, the Silver works just fine.

Today if you fork this project: BeagleV-Fire / Gateware · GitLab (develop branch: Files · develop · BeagleV-Fire / Gateware · GitLab ) Pipelines · BeagleV-Fire / Gateware · GitLab

You’ll get a fpga project build from ci: build-job (#17772) · Jobs · BeagleV-Fire / Gateware · GitLab

REgards,

2 Likes

May I suggest that all the scripts and things that need to run on the command line be put in one place at/on BeagleBoard.org · GitHub

That way I won’t need to discover that the .job file that is supposed to be in Program_Debug_v2032.2 is not to be found.

I find that in order to make Libero work I must first start the lmgrd manually.

I’m really at a loss to understand why the tools are so aggravating to install.

I suppose it may have to do with the fact that its almost 20GB that need to find a new home without error.

Regarding Libero license, you only need the Silver license which gives you the same FPGA tools as the other licenses (including Synopsis Identify).
I always find the place to request a free Silver license difficult to find but it is on the Microchip FPGA licensing page: https://www.microchip.com/en-us/products/fpgas-and-plds/fpga-and-soc-design-tools/fpga/licensing. Look for the words “free license” on that page. This will bring you to the MicrochipDirect site where you have to register before getting your free license.

This looks interesting, have you tried anything with this?

Only made sure a loopback at 5Gbps works. I had misread the SYZYGY spec and thought the connector was rated for only 5Gbps but it does not look like there is a limitation on the connector. Worth a try at 12Gbps. SmartDebug can generate an eye for these signals. The eye looked good at 5Gbps.

Not sure how to get an accurate measurement with that. Seems like a stretch, even Pi is going out on limb with Pi5 and claiming, I believe dual 10Gbs with a HAT. That funky connector (pi board) does not seem like it could even handle 1 Gbs as in sustained and no errors… That would be nice if that V board really did hit the 12Gbs with extremely high reliability.

Silver2row:Thanks for your comments, they have been most helpful and encouraging.

I find that Libero runs fine on 20.04, no surprise there. The most valuable lesson was:

When running multiple OSs one must run update-grub to see all the bootable partitions.

The Gitware RobertCNelson refers to is key!

Using 20.04 feels alien.

1 Like

I faced the same problem and found no solution at the time so I gave up and returned the board.

For the last week or so I’ve been busy with Kicad laying out a ZYSYGY to USB-C interface. While an inch may not seem like a lot, at 12.5 GHz every mil matters. So does, ESD protection and so on…

About 1/2" could be saved by extending the interface beyond the present PCB outline … the gods shudder.

Any pros and cons ?

From the gateware directory

libero SCRIPT:BUILD_BVF_GATEWARE.tcl

it runs for a while up to synthesis and then it hits the fan

Starting:    /home/flash/opt/microchip/Libero_SoC_v2023.2/SynplifyPro/linux_a_64/mbin/synbatch
Install:     /home/flash/opt/microchip/Libero_SoC_v2023.2/SynplifyPro
Hostname:    Ubuntu20
Date:        Thu Nov 30 13:29:50 2023
Version:     T-2022.09M-SP2-1

Arguments:   -product synplify_pro -licensetype synplifypro_actel -batch -log synplify.log BVF_GATEWARE_syn.tcl
ProductType: synplify_base

No such feature exists.
Feature:       synplifypro_actel
License path:  /home/flash/opt/microchip/license/License.dat:
FlexNet Licensing error:-5,21


Host ID:  "dc85de59bc2d 60a44cae4fd3"
Please contact support at https://solvnetplus.synopsys.com/ManageCase?ccf=1

Running in Vendor Mode

Error:  Synthesis failed.
Error:  The command 'run_tool' failed.
Error:  Failure when executing Tcl script. [ Line 270 ]
Error:  The Execute Script command failed.
The BVF_GATEWARE_025T project was closed.

Any ideas?

Looks like licensing problem. Can you start Libero and open the libero project that was created in the work directory and try to run synthesis from the GUI. That will tell us if this is a general Libero license issue or something more specific with running the scripts in command line.

Well, getting solid data is more important than speed.

Would like to know what the test setups are for the the claims. Not not picking on this board, its a fairly common issue with others.

I got ripped on some fiber networking stuff, bought it on amazon. Dual channel that is not even close to what they claim. It gets even worse, it sat out in the shop way past the return date. By the time it was tested it was too late to return it, about all it is good for is emi, emp and lightening protection, it sure was not speed.

Until the manufactures can post the exact test setup its all a pile …

Generated a case with microchip. They recommended loading new daemons from https://www.microsemi/com/document-portal/doc_download/131989-linux-daemons.

Like magic, I’m getting through synthesis.

If you are having any problem with the tools. DON’T hesitate to open a trouble ticket with microchip. They are very responsive.

The quality of the communications channel for a wired interface should be at least 10exp-9. with the necessary test mechanism built into the device.

Knowing your bit error rate is essential. However that alone only tells you there is a problem. Not where. Having access to the eye patterns is really helpful.

I had no issues with the licensing (other than the fact that only one copy of libero can run at a time). I couldn’t get Microchip-FPGA-Tools-Setup to work either. So I ended up hacking it by putting in my bashrc:

export SC_INSTALL_DIR=~/microchip/SoftConsole-v2022.2-RISC-V-747
export LIBERO_INSTALL_DIR=~/microchip/Libero_SoC_v2023.2
export LICENSE_DAEMON_DIR=~/microchip/license/bin
export LICENSE_FILE_DIR=~/microchip/license
export FPGENPROG=$LIBERO_INSTALL_DIR/Libero/bin64/fpgenprog

and appended the LM_LICENSE_FILE with the location of license.dat from Microchip (it’s in LICENSE_FILE_DIR and the binaries are in LICENSE_DAEMON_DIR). Then I run “lmgrd -c $LICENSE_FILE_DIR/license.dat -l /tmp/uchip.log”. lmdown (which is not provided by Microchip but available from licensing of questa/modelsim) is useful for shutting down the microchip daemons.

I did get to install libero and the other software under a root directory (/opt) but then installing cores is a pain as those need to be at a non-user location and one has to run everything with “sudo libero LM_LICENCE_FILE=$LM_LICENSE_FILE” to update the cores. Plus not sure it is useful for a multiuser environment since only one copy of libero can run at a time anyway (for the free license).

My install is on Linux Mint 21.