bad image from online image builder


I tried to install Angstrom on 2 BeagleBoard (rev. B5 and B7)
generated by the online image builder
It booted but it didn't work properly for several reasons:

1) There are some inconsistencies in the generated images. The image
file from the /boot/ directory is called "uImage-2.6.29-omap1" whereas
the uname output is:
root@beagleboard:~# uname -a
Linux beagleboard 2.6.28-omap1 #1 Tue Mar 24 18:57:27 CET 2009 armv7l

2) When the linux was booting and wanted to load the modules, there
was the following error:
modprobe: FATAL: Could not load /lib/modules/2.6.28-omap1/modules.dep:
No such file or directory

The /lib/modules/2.6.28-omap1/ didn't exist.
There was only the /lib/modules/2.6.29-omap1/ directory, without any
modules.dep file.

To solve this, I logged in as root using the serial connection,
created a symlink to get:
/lib/modules/2.6.28-omap1/ -> /lib/modules/2.6.29-omap1/
and finally run:
root@beagleboard:~# depmod
to populate the /lib/modules/2.6.29-omap1/ folder.

After reboot, it worked.

Does any of you encounter this kind of problems?
Is there any other solution ?



That's not an inconsistancy in the builder, *you* installed 2.6.28 on the vfat partition and told uboot to boot that