BB C4 can't login in GUI after opkg update; opkg upgrade

I installed Angtrom image from
and everything worked fine untill I run opkg update and then opkg
upgrade. After reboot it shows login screen with on-screen keyboard,
then I enter my password and screen became black with X cursor for a
few seconds and then I saw login screen again and again. Has someone
this trouble? How to solve it? Why it happened?

Are you using a dedicated power supply with plenty of current capacity? I had a similar problem using USB power, then I switched to a 5V brick and STILL had the problem. I then noticed the power brick was rated at 300ma, so I switched to one that supplied 2.5A (from a network router I had laying around) and it worked fine.


I have been having problems installing items from the opkg repositories recently. I saw a mention on this list that the angstrom site is being bandwidth throttled because of the quantity of bits they’ve been shipping out. That may be part of the problem with upgrading or installing.

The other problem I’ve run into when starting from a somewhat old system has been that there are a large number of packages that need to be upgraded, and it exceeds the size of the temporary space during the download stage. The was what appeared to mess up my running system. (The /tmp directory was normally in a ram filesystem.)

I’ve been trying to rebuild my system for the past week and having problems getting packages to download because of the first problem. I’ve been adding “-t /home/root” into my opkg commands recently just to force it to use a filesystem that I know will not run out of space during an install or upgrade.

the tmp location problem has been fixed in recent versions :slight_smile:

the tmp location problem has been fixed in recent versions :slight_smile:

Thank you, Koen. I will try it.

My system is powered from 5V/2.5 AC/DC so the power should me enough.
I think that 4Gb SDHC should have enough capacity too.


It's terrible. I made opkg update and opkg -t /usr/etc/ upgrade and
leave my beagleboard to work whole night. This morning I saw last
message in terminal: "Segmentation fault". I made reboot and after
system was falling. It shows black screen with flashing X cursor... No
login screen, no console selection CTRL+ALT+F#...

I need advice how to make safe update of my system. Can someone give
me working Angstrom Beagleboard image that is newer than March 2010?
Or give me, please, detailed steps how to safely upgrade downloaded
demo image.

P.S. the size if /usr/etc/opkg-fudmSK was 100MB.

I am having the exact same problem. Getting Beagle up and running
with Angstrom seems to be an uphill battle, what with the out-of-date
image, single repository server that only lets you download at 5 Kbps,
and opkg that segfaults in the middle of updating because it runs out
of room, causing the update to start all over again... grr.

Is there a way we can donate money, time, bandwidth, or anything else
in order to get these problems fixed?

What I would like to see:
--A "known issues" list for the most recent (March, 2010) Beagle
image, including how to work around problems with opkg
--A path towards creating official mirrors of Angstrom
--A path towards making it (relatively) easy to have more up-to-date
images for targets like the Beagle (an autobuild server, perhaps, or
even just a wiki page explaining how to build the image from the
packages on the repo?)

I know this reads like "want, want, want" but there is little
information on the angstrom-distribution website about what we, the
users, can do to help support the distro in this time of "crisis."
Until the bandwidth issues are resolved, I am unable to set up a
working, up-to-date Angstrom install on my BeagleBoard, and I'm sure
others who are in the same boat would like to know what the developers
think the best way to support getting this solved would be.

Jon Evans

Actually, I'm going to go ahead and put my foot in my mouth.
Narcissus started working for me today, and I was able to build a
working image.

My steps:
--Go to
--Select Beagleboard target, Advanced mode, Unstable branch, Extended
base system
--Select udev, .tar.gz
--Pick the options I want from the expando-menus below. Make sure to
pick all of the TI drivers if you plan on using the DSP!
--Assemble the image and download it
--Extract the .tar.gz file to somewhere on my Linux box
--Copy the contents to the Angstrom partition of my already-working SD
--Modify /etc/default/usb-gadget and /etc/network/interfaces to enable
USB networking and configure the static IPs how I like them
--Boot the BeagleBoard from this new image, reset my user accounts,
and start going! opkg reports nothing needing updating (well, I
should hope so, since I just built the image from the repo an hour

Best of luck to my fellow Beagle users,