bb-code-server and starting to get errors on building and keeping it up while running!


bb-code-server is not working. Is there a reason this has failed recently? I am trying to track down the cause currently…

That is the site I found so far via looking through the .service file. Anyway, I am not going to change things so far. I just wanted to give a heads up to anyone working on it.


P.S. Oh!

● bb-code-server.service - Code Server
     Loaded: loaded (/lib/systemd/system/bb-code-server.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Sat 2022-09-17 19:32:57 CDT; 10s ago
    Process: 2285 ExecStartPre=/bin/ln -sf /opt/vsx-examples/examples/ /home/debian/ (code=exited, status=0/SUCCESS)
    Process: 2286 ExecStartPre=/bin/mkdir -p /home/debian/.local/share/code-server/User/ (code=exited, status=0/SUCCESS)
    Process: 2287 ExecStartPre=/bin/cp /opt/vsx-examples/examples/settings.json /home/debian/.local/share/code-server/User/ (code=exited, status=0/SUCCESS)
    Process: 2288 ExecStart=/opt/bb-code-server/app/bin/code-server --cert --auth none --disable-telemetry --disable-update-check --config /opt/bb-code-server/config/config.yaml --extensions>
   Main PID: 2288 (code=exited, status=1/FAILURE)
        CPU: 26.019s

I am currently working to make some posts work but to not a success in sight is the current times.


Just some updates:

  1. I tried to install the newest version and it worked. The install worked.
  2. The server does not work for me. Is anyone having this issue yet?
  3. I will keep trying to track down the culprit and soon.


P.S. 1. through 3. are useless. I am out of control of bb-code-server. It is not in my hands. If you are in control of this repo, please come forward.


The server works. I just erased it, reinstalled it, and then ran sudo systemctl status bb-code-server.service.

The status comes back a-okay. It says running but when I go online locally on my desktop, the address reports that it is unreachable.


P.S. I think it is something w/ credentials that keeps my computer from listening to my commands. It seems maybe a credential is outdated (out on a limb here).

‘https://[ip address]:3000/’

Main PID: 2288 (code=exited, status=1/FAILURE)
        CPU: 26.019s

Something is fishy .



@RobertCNelson , is it that it is https instead of http?


P.S. Or…is it on my side of things?