`bb.org-debian-buster-iot-v4.19.conf` build failing on bone101 install (cloud9 permissions)

We have a custom build system to generate our beaglebone images, and a couple of weeks ago the builds started to fail with:

Setting up bone101 (2.1.3-0rcnee13~buster+20200713) ...
Setting up: /var/lib/cloud9/ permissions
Updating Cloud9 examples from: https://github.com/beagleboard/cloud9-examples
fatal: detected dubious ownership in repository at '/var/lib/cloud9'
To add an exception for this directory, call:

	git config --global --add safe.directory /var/lib/cloud9
dpkg: error processing package bone101 (--configure):
 installed bone101 package post-installation script subprocess returned error exit status 128
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Our build system does the following:

  1. Clones GitHub - RobertCNelson/omap-image-builder: omap image builder
  2. Runs ./scripts/install_dependencies.sh
  3. Runs ./RootStock-NG.sh -c custom-bbgg-image

Where the custom bbgg image is a copy of bb.org-debian-buster-iot-v4.19, but changes the default user/pass, adds a python package, and adds a chroot_before_hook script.

Trying to do the above sequence, using the provided -c bb.org-debian-buster-iot-v4.19 instead of our custom one, failed with the same error. I’ve tried to add git config --global --add safe.directory /var/lib/cloud9 to our sequence, but i think because of the chroot shenanigans it doesn’t properly percolate down into the chroot.sh call.

Do you have any recommendations/how was this properly built?

Oh, looks like this change to git in Debian Buster broke it…


i just need to update the package and add the “safe.directory” hint…


Thanks @Michael_Liberato Fixed and pushed with:

My CI build bot shows all green now…


That seems to have fixed our CI too. Really appreciate the quick turn around, cheers!