BB with Angstrom - Internet not working!!!!!


I'm new to BB and Angstrom. I have connected all the wires correctly
and gotten to the login screen. When I try to ping a website it comes
back with the following message:

ping: bad address ''

I have been running around in circles on the internet trying to solve
this issue with no avail. Can someone please provide me with detailed
instructions on fixing my problem. Thanks so much!!!


First ping one IP address (next gateway per example) not site like and check network configuration Gateway, NetMask, DNS, etc…

Tanks Armando.

2010/6/15 V <>

Hi V,

Maybe this will help you


You need to make sure you have the interface up (use ifconfig) and
configured with the correct IP address.

If you are using usb0 over the OTG interface, the host USB computer
must also have its end of the CDC ethernet configured.

You can try this link for more info (not the NFS stuff though) about
USB OTG interfaces

Using ifconfig I have found that "eth0" doesn't show up, and according
to a number of sources I think it is needed for internet connection to
work properly. Can someone confirm this? I hope this helps someone
know what should be done for me to get internet.


After noticing that my eth0 connection didn't show up on my ifconfig,
I decided to try some more commands and got the following results:

~# ifconfig eth0
ifconfig: eth0: error fetching interface information: Device not found
~# ifup eth0
ifup: interface eth0 already configured

Another round of searching through the web about this problem led me
to <
msg02713.html> and the problem seems to be the same, although I am not
using a zippy board. Will the solution still work? I don't want to
cause more problems.


Have you followed the instructions in the Angstrom manual?

Here's what I did:
* Connect USB OTG port to host PC via USB cable (this provides power
and ethernet).
* Wait for boot
* Loaded g_ether module
* ifconfig usb0
* ip route add default via <PC address>
On PC:
* Watch usb0 come up in /var/log/messages
* ifconfig usb0
* Enabled IP forwarding
* Setup IP masquerade on the PC

Okay, I have realized that I had USB problems earlier due to using a
Rev C3 board and now have seemed to have fixed them. I'm now using the
OTG port as my host port for USB using a USB to USB connector. The BB
detects the eth0 connection and pinging seems to work, but the
internet is still not working.

Here are a few commands and their results:

root@beagleboard:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:14:D1:1B:45:38
          inet addr: Bcast: Mask:
          inet6 addr: fe80::214:d1ff:fe1b:4538/64 Scope:Link
          RX packets:3499 errors:0 dropped:0 overruns:0 frame:0
          TX packets:616 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:406784 (397.2 KiB) TX bytes:68010 (66.4 KiB)

lo Link encap:Local Loopback
          inet addr: Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:600 (600.0 b) TX bytes:600 (600.0 b)

root@beagleboard:~# ifconfig usb0
usb0 Link encap:Ethernet HWaddr EA:D0:33:BC:7C:16
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

root@beagleboard:~# ping
PING ( 56 data bytes
64 bytes from seq=0 ttl=53 time=562.256 ms
64 bytes from seq=1 ttl=53 time=191.772 ms
64 bytes from seq=2 ttl=53 time=36.285 ms
64 bytes from seq=3 ttl=53 time=35.797 ms
64 bytes from seq=4 ttl=53 time=36.377 ms

--- ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 35.797/172.497/562.256 ms

root@beagleboard:~# wget
--2010-03-19 14:30:02--
Resolving,,, ...
Connecting to||:80... connected.
HTTP request sent, awaiting response...

The last command stays in the "awaiting response..." stage until a
(Ctrl+C) is needed to get the prompt back up. Does someone know a
solution to get my internet working? Thanks so much!


Since is resolving to an IP address, it looks like you actually are connected. What are the results from “ping”?


I have tried that command and have listed my results in my previous
post. Ping seems to be working fine.


Yes, I see it now. That shows that you are connected to the Internet and DNS is working.

However, the result from “ifconfig usb0” does not show an ethernet address. It should have a line like “inet addr:ww.xx.yy.zz Bcast:…”

I am just now writing up the process for setting up a tunnel via USB from an Ubuntu host, so I am very curious about getting this to work as well! :slight_smile:

Out of curiosity, can you wget any other pages besides the google home page? How about “wget”?

Hi Jeff,

I have typed some more commands with interesting results. This time I
tried different websites using wget, nslookup, and traceroute. It
seems like on some websites nslookup seems to work and some
( it doesn't, and traceroute doesn't seem to get past the
first step. All of this leads me to guess that there is a problem with
the DNS, I'm not sure if this is correct.

I have the commands and results below:

root@beagleboard:~# wget
--2010-03-18 16:18:22--
Resolving,,, ...
Connecting to||:80... connected.
HTTP request sent, awaiting response...

root@beagleboard:~# wget
--2010-03-18 16:18:56--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `index.html'

    [ <=> ] 74,600 --.-K/s
    [ <=> ] 74,600 --.-K/

root@beagleboard:~# wget
--2010-03-18 16:20:32--
Resolving failed: Name or service not known.
Resolving failed: Name or service not known.

root@beagleboard:~# nslookup
Address 1:

Address 1:
Address 2:
Address 3:
Address 4:

root@beagleboard:~# nslookup
Address 1:

nslookup: can't resolve ''

root@beagleboard:~# nslookup
Address 1:

Address 1:
Address 2:

root@beagleboard:~# traceroute
traceroute: warning: has multiple addresses; using
traceroute to (, 30 hops max, 38 byte packets
1 ( 1.618 ms 2.808 ms 0.854 ms
2 * * *
3 * * *

root@beagleboard:~# traceroute
traceroute: Host name lookup failure

root@beagleboard:~# traceroute
traceroute: warning: has multiple addresses; using
traceroute to (, 30 hops max, 38 byte
1 ( 1.312 ms 1.251 ms 0.732 ms
2 * * *

Once again I required a cancel (Ctrl + c) to get out of wget and
traceroute. I hope this might provide further insight to what my
problem is. If someone has a solution please post it, thanks!!!


Have you changed /etc/resolv.conf?

/etc/resolv.conf needs to contain nameserver entries that are local to
you otherwise the system could be doing DNS lookups across the globe.

Hi Richard,

I have modified it, but it appears that it is recreated on startup by
NetworkManager to a default configuration. I have also added some
websites and ip addresses on the /etc/hosts file, and wget seems to
work on those but load bar always stops at around 98-99% and gets
stuck there. At this point I'm completely baffled by this problem and
I've had it for 3-4 days. If anyone has any idea on what to check or
modify next, please post it.


The only thing I can think of that changes resolv.conf is a DHCP
client. Are you running one? If you are the server needs to provide
sensible DNS settings.

Is there any NetworkManager or similar daemons running that might
interfere with network config.

If you manually change resolv.conf, do you get better performance
while it is changed?

The stopping at 99% is baffling. The network cannot know how big the
file is. Try different files and servers.

Can you run a web/file server on your dev PC and transfer from that OK?

Might also be worth turning off TCP window scaling as this can break
data transfers when they begin to ramp up. There could be some old
gateway in the path that does not understand window scaling.

Run tcpdump/wireshark on the PC. This will shed light on what is happening.