BBAI use SDCard for extra storage

Hello people,

I’m trying to use the SDCard on the BBAI for extra storage.

  • I have successfully flashed Debian Console image onto the EMMC using the published flasher images.
  • Next, I formatted a new microSD Card with MBR and create a FAT partition
  • Next, I created a uEnv.txt in that partition with the contents
mmcroot=/dev/mmcblk1p2 ro

I was using this article as a reference :

However, when I insert the microSD card and reset the board, I don’t see anything on the serial console.

Usually, I can see

U-Boot 2020.10-rc1-00001-gc5bc0aaa70...


but when I have this microSD card inserted, I don't see anything.

What am I doing wrong?

On the BBAI, if you want to use the microSD as extra storage, do NOT
create any files named "uEnv.txt" under /, or /boot/ , etc..

Then u-boot will happily ignore it..

The BBAI (am57xx) has a different boot order then the BBB (am335x), on
the BBAI the microSD is always first, where as the BBB the eMMC is


Thanks Robert.

OK. I removed the uEnv.txt from the microSD card (so now I have an empty FAT partition on the card). But it’s still doesn’t seem to want to boot. The serial console is empty… :frowning:



I managed to get it to boot by completely erasing the microSD card and formatting it as EXT4.

Thanks, everyone!

We had a similar issue on the BB-X15 (am57xx) a few year’s back, where the primary image (SPL, u-boot, kernel, debian) was flashed to eMMC. We were using an SD card for logging, and the SD card was formatted as FAT to allow reading from Windows. However, an improperly formatted SD card inserted in the slot caused the BB-X15 to not boot.

Ran this by TI E2E, and the guidance from TI was that if the first word on the SD card is neither 0x00000000 nor 0xFFFFFFFF, the boot ROM tries to boot from the SD card instead of moving onto the eMMC.

This guidance assumes that the boot ROM on the BBAI behaves the same way, but at least it’s potentially useful info…

How did you manage to do it? I also try to format the SD card in EXT4 but, when I reboot te BBAI still tries to boot from SD Card, and nothing appear until I eject the SD card.

It was a dead SDCard for me. Worked fine with another card.