BBAI64 _ How many UART active?

Hi.
UART-1, UART-5 has been activated through overlays operation.

edited /boot/firmware/extlinux/extlinux.conf
“fdtoverlays /overlays/BONE-UART1.dtbo /overlays/BONE-UART5dtbo”

UBOOT: Booted Device-Tree:[k3-j721e-beagleboneai64.dts]
UBOOT: Loaded Overlay:[BBAI64-CSI0-imx219.kernel]
UBOOT: Loaded Overlay:[BONE-I2C1.kernel]
UBOOT: Loaded Overlay:[BONE-UART1.kernel]
UBOOT: Loaded Overlay:[BONE-UART5.kernel]
kernel:[5.10.153-ti-arm64-r84]
debian@BeagleBone:~$ ls /dev/bone/uart
0  1  5

I want to use five UART Serials and don’t know what to do to use more UART serial.

Hi @ALEX_PARK those were just the first uart’s i got physically working… I need to go back thru the list now that more of the peripheral clock and power have been enabled on the core.

Regards,

2 Likes

Thankyou @RobertCNelson. Successed five UART open.
‘k3-j721e-beagleboneai64.dts’ was modified and succeeded.

1 Like

Do you know where I can get a copy of the overlays? I did a git pull to my /opt/source/dtb-5.10-ti and it is up to date. I have only one UART overlay and it is for UART1. Also what other changes are required.

$ sudo beagle-version | grep UBOOT
UBOOT: Booted Device-Tree:[k3-j721e-beagleboneai64.dts]
UBOOT: Loaded Overlay:[BONE-PWM0.kernel]
UBOOT: Loaded Overlay:[BONE-PWM1.kernel]
UBOOT: Loaded Overlay:[BONE-PWM2.kernel]

I need to look back into this, I just had one uart initially working… src/arm64/overlays · v5.10.x-ti-unified · BeagleBoard.org / BeagleBoard-DeviceTrees · GitLab

Regards,

I tried to add the BONE-UART1.dtbo to the extlinux.conf. I then copied the BONE-UART1.dtbo to the /boot/dtbs/5.10.153-ti-arm64-r86.ti.overlays folder. The reboot failed, so I removed the line in the extlinux.conf that I just added for BONE-UART1.dtbo. I have noticed that their is no fragment for main_uart1 or main_uart2, in the k3-j721e-beagleboardai64.dts. Also uart3, uart6, uart7, uart8, and uart9 have status=“disabled”.

$ cat /opt/source/dtb-5.10-ti/src/arm64/k3-j721e-beagleboneai64.dts
main_uart0_pins_default: main-uart0-pins-default {
&wkup_uart0 {
&main_uart0 {
pinctrl-0 = <&main_uart0_pins_default>;
&main_uart3 {
&main_uart6 {
&main_uart7 {
&main_uart8 {
&main_uart9 {

BONE-UART1 on the expansion header is $main_uart2 on bbai64 soc. Beagleboard:BeagleBone cape interface spec - eLinux.org

Regards,

I actived five uart port.
I modified ‘k3-j721e-beagleboneai64-bone-buses.dtsi’

bone_uart_3: &main_uart3 {
/* tested /
pinctrl-names = “default”;
pinctrl-0 = <
&P9_17_uart_pin /
uart3_txd /
&P9_12_uart_pin /
uart3_rxd */
;
symlink = “bone/uart/3”;
status = “okay”;
};

A similar correction would do.
I referred to the pin map [Connectors — BeagleBoard Documentation]

/home/pops/opt/source/dtb-5.10-ti/src/arm64/k3-j721e-beagleboneai64.dts did you change:
from:
&main_uart3 {
/* UART not brought out /
status = “disabled”;
};
to:
&main_uart3 {
/
UART not brought out */
status = “okay”;
};