BBB cannot access Internet


I am an absolute beginner with the BeagleBone Black and Linux, the learning is not easy …
I can boot my BBB from the SD Card and then get access the board from the browser.

The BBB is connected to my laptop through USB and I also tried to connect through the Ethernet cable, while USB is used as Power Supply.

There I see the message that I “need to upgrade my SW”. However I have been fighting a few days and so far I have failed. I am trying to get the update by performing git pull, but that what I see:

fatal: unable to access ‘’: Could not resolve host:

I removed Antivirus and tried to disable Windows firewalls - still can’t. I did that because I believe the problem is in some TCP IP Network configuration on my laptop.

I tried to follow these instructions:

I am facing the same result. Derek in the article above writes:
“The BBB then has a static IP address after reboot. The same procedure applies to other adapter entries, such as the wlan0 wireless Ethernet adapter. Do not pick an address that is within the DHCP pool or assigned to another device, or it will result in IP conflicts on the network.” Actually did not apply the required procedure on my laptop, because I actually didn’t understand the instruction.

Do you have any idea that can help me to troubleshoot and resolve the problem? Thank you in advance for any help !


Try the instructions from this link. It works for me:



Thank you Jonny!

Your link looks great. Some of the steps I already performed, but some - I will hopefully try this evening. The article also helped my to realize a mistake. I saw a different configuration for Ethernet and WiFi, but I thought it refers to how my BBB is connected to the laptop, while now I understand it refers to how my laptop is connected to the router.

Will update you with the result.
Appreciate your help !


בתאריך יום ג׳, 2 בפבר׳ 2021, 21:45, מאת jonnymo ‏<>: