BBB - can't use lighttpd

I installed lighttpd and I am not able to run it as a command in terminal do I need to set it as an environment variable?

Depending what version you started with, apache2 or nginx is already installed and using port 80… Make sure you disable them, before running lighttpd…

You can also run:

sudo systemctl status lighttpd

to see why it failed…


I can’t find .bash_profile on my BBB.

However I am not able to execute lighttpd from the command line.

Command 'lighttpd' is available in '/usr/sbin/lighttpd'
The command could not be located because '/usr/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative privileges associated with your user account.
lighttpd: command not found

I was able to start it.

\u25cf lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor pres>
Active: active (running) since Sun 2023-06-18 18:49:13 UTC; 298ms ago
Process: 24305 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttp>
Main PID: 24311 (lighttpd)
Tasks: 3 (limit: 1010)
Memory: 996.0K
CPU: 1.950s
CGroup: /system.slice/lighttpd.service
\u251c\u250024311 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
\u251c\u250024312 /bin/sh -c /usr/share/lighttpd/ 80
\u2514\u250024313 /usr/bin/perl -w /usr/share/lighttpd/ 80

Jun 18 18:49:11 BeagleBone systemd[1]: Starting Lighttpd Daemon…
Jun 18 18:49:13 BeagleBone systemd[1]: Started Lighttpd Daemon.

lines 1-13/13 (END)

Here is the output. I don’t think it is running now.

\u25cf lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor pr>
Active: activating (start-pre) since Sun 2023-06-18 18:46:45 UTC; 2s ago
Cntrl PID: 23994 (lighttpd)
Tasks: 3 (limit: 1010)
Memory: 1.1M
CPU: 1.780s
CGroup: /system.slice/lighttpd.service
\u251c\u250023994 /usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf
\u251c\u250023997 /bin/sh -c /usr/share/lighttpd/
\u2514\u250023998 /usr/bin/perl -w /usr/share/lighttpd/