BBB connectivity from Yosemite at 192.168.7.2

Hi,

I am getting erratic connection access via USB to the 192.168.7.2 in Yosemite 10.10.5. In Network, I’ve had luck by switching the ‘BeagleBoneBlack’ interface from DHCP to DHCP with manual address and setting it to 192.168.7.1. Sometimes switching it back to DHCP makes it get the 192.168.7.1 ip correctly. Now, the DHCP option just shows no IP and clicking advanced > renew DHCP lease will not bring anything

I can access the BBB via tty:

screen /dev/tty.usb* 115200

ifconfig -a usb0
usb0 Link encap:Ethernet HWaddr b0:d5:cc:ff:e7:d0
inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252
inet6 addr: fe80::b2d5:ccff:feff:e7d0/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:134 (134.0 B)

I’ve tried doing /sbin/route add default gw 192.168.7.1 but I still cannot ping to the host (Host Unreachable)

previously, it has ‘fixed itself’ by shutting down the BBB (always with shutdown -h now inside terminal) unplugging and plugging back into host, but now that is not helping either

I also tried deleting the network interface, and creating a new one. That worked one time and I got access to 192.168.7.2 and the C9 ide at 192.168.7.2:3000, but it doesn’t seem to work anymore either

Any ideas how to solve/debug this?

Screen Shot 2017-09-13 at 10.25.37 AM.png