BBB dead after flash

I managed to try and flash my BBB with the image on the website but after it completed the process and I tried to reboot the board simply does not work. I tried booting again via SD card, turning off the power, changing to another type of SD card, changing power supply and nothing will make the device stir. Is there any way I can absolutely verify that there’s no way to repair this guy (or see if it’s completely dead vs “mostly dead”)? I’m lured by very technical challenges but the internet seems to be failing me at the moment.

If nothing else, can there be a RMA? I purchased this device at the maker faire last weekend.


You most likely did something wrong. Which instructions did you follow?


I used the instructions at this URL:
I got the latest image from this one: (I used the top image).

I would later be informed in the IRC channel to use the image found on this URL: (production image 2013.09.04)

Yes, please use my Wiki Follow it to the letter. No shortcuts. No USB power. No Ethernet.


I presume you’re referring to this:

Nope. The link that is on the little white card that came in the box with the board.


OK, so now I can see where things went wrong. I had been flashing the BBB with it connected to my laptop (which would explain why my USB ports were killed later that day). This makes me believe that the issue is that the eMMC was disrupted during the flashing process. However, would this also create issues with booting to the microSD after the fact? I will be getting an FTDI connector tomorrow to help troubleshoot the issue and see what’s really happening on the board.

That is exactly why I say in the instructions to use DC power.


When trying to view what’s happening via the FTDI the unity basically puts out no output with the exception of the occasional “C”. Is there any chance that this can be repaired? As stated earlier in this thread, the “boot button” option does not seem to work.

The boot button completely bypasses the on-board eMMC, so if your 'bone
is not booting correctly from SD card when holding the boot button
during reset, you need to re-image the SD card.

That indicates there is nothing in flash and nothing on the SD card that it can boot from.


Based on the instructions provided I’ve done everything to the letter. Unfortunately, this is all I see via the FTDI output via the terminal command “screen /dev/tty.usb… 115200”:
U-Boot SPL 2013.04-dirty (Jun 19 2013 - 09:57:14)
musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, HB-ISO Rx, HB-ISO Tx, SoftConn)

Then I suggest you request an RMA and let the factory folks do it for you.


I purchased this unit at the Maker Faire (NYC a few weeks back). Does this unit still apply to RMA?

I don’t mind getting my hands a bit dirtier but it’s hard to find documentation online. Is there a way we can blast/test it via FTDI (if not some other method)?

Yes it is covered.


I got the device today and I wanted to upgrade the firmware. Before I do that I wanted to ask if there’s any way I can verify what’s already installed and therefore know if I actually succeeded in updating the unit. Thanks for your help.

cat /etc/dogtag

will display the version of Angstrom installed on the device.
Once the eMMC is flashed successfully, the four USR LEDs will remain lit.

Hmm. Maybe go to the support wiki???


Thanks so much folks. I often find myself trudging through the IRC and site (along with google searches) to no real good results. The circuitco site is definitely bookmarked at this point and I’ll be sure to RTFM going forward. Just curious, what’s the difference between CircuitCo & Seems like the wiki would be more publicly visible on the latter.

Either way, life is good and thanks a bunch. Just had a kid and baby brain isn’t helping. Thanks again and again and hopefully the next question will be something tricky. :slight_smile:

Circuitco is the manufacturer of all the BeagleBoards. They work for me.

Right now, they are hosting the Wiki. We hope to move it soon to another host.