BBB does not appear as USB drive

Brand new BBB, followed directions to connect USB and install Mac drivers. BBB does not show up as a USB drive (or at all) and browsing to times out.

I’ve tried:

  • reflashing several times
  • connected to Windows machine
  • different mini-usb cable
  • booted Angstrom from microSD card

The board works; when HDMI monitor and keyboard/mouse is connected, the desktop runs just fine.

Anything else to try or should I request an RMA?

Thanks for any ideas.

Just to be sure, you installed your drivers from here right?

We can check that the driver installed correctly by checking the Device Manager.

Windows: Go to Start, Run, and type ‘mmc devmgmt.msc’ to open Device Manager.
If your computer is reading your BBB correctly, BBB should be listed under Gadget Serial (COM#).
If you look around the Device Manager and see an item with a yellow exclamation mark, your drivers didn’t install successfully and that is most likely your BBB.

Yes, the drivers were downloaded from there. I will go through the steps you outline tonight to see result.
Question - If plugged into the USB port of a machione with no drivers installed, should the BBB still show up as a USB thumbdrive?

I know it does on windows machines.


I would also try this website for your Mac:

OK, went through the procedure on a windows laptop with the drivers installed; nothing showed up in device manager.
To summarize, doesn't show up as a USB device on any of my macs or windows laptops (installed drivers on all), can reach with browser at It does boot to the angstrom desktop with a monitor and keyboard attached.

Any other ideas anyone can think of?

Thanks for your help.

Oops, that should have been "can't reach with browser at It does boot to the angstrom desktop with a monitor and keyboard attached.

Thanks again.

I’m having the same issue. Did you ever figure it out?

Brand new BBB, plugged it in to USB, no disk drive appears. No output in dmesg. No USB device shows up at all.

Very disappointed in my first BB so far. :confused:

It takes about 2-3 minutes for the drive to show up, after the kernel on the board has booted up and the PC has recognized it…


Thanks, but I've left it plugged in much longer than that. I tried updating the device via microsd as well, seemed to update fine but still no USB.

thanks, but I've left it plugged in much longer than that. I tried updating with the micro SD card as well. The update bean to take, but still no USB connectivity.

Try changing out the USB cable.

I also suggest you register so your posts are not moderated.


if we're talking about how long it takes for /media/BEAGLEBONE to be
mounted and accessible on the host, it takes only a few seconds from
when i plug in my BBB via USB tether. is that what we're talking


Yes. I have seen it take longer on some PCs.


Which host OS ?

Hi, I just bought my BBB for the first time too, I followed the instructions on the site and downloaded the drivers first, then installed them, after installing, I plugged the BBB in the USB and it detects it but it doesn’t recognize it as a USB device which is very confusing considered that I didn’t flash the eMMC or anything of the sort. I keep removing the drivers and reinstall them but still the same result. I can’t see it as a USB device but the Windows detects it in the port but can’t configure the drivers for it (other words the yellow exclamation mark on the BeagleboardBlack in Device Manager). Is there an updated version of the drivers maybe or is there a step that i missed in the instructions because I followed from the beginning. Any help would be very appreciated. Thanks.