BBB does not boot - only power LED on. USR LEDs OFF

The BBB was working fine till now, using it from couple of months. Now suddenly, the BBB does not boot either by SD-Card or eMMC. When powered by USB or 5V power jack, only the Power LED is on (stays on).
But all USR LEDs are off. And i have attached to serial console, no output to serial as well.
Is the board dead ??

Can anyone please help me out here…

Grab the minimal image from here:

Use to flash it to a microSD…

  • Stick your microSD into the board
  • Hold the boot button
  • Insert power
  • Report what shows up over the serial port


Thanks for the response.
Flashed am335x-debian-11.5-minimal-armhf-2022-10-01-2gb on to microSD.
Pressed the boot button for few seconds during power up.
There is no output on the serial console ! and only power LED is on. tried the powerup cycle couple of times. Also tried both USB and power jack.
Thanks and Regards,


Sadly, looks like it’s now time to recycle that board…


Oh that’s bad. Also checked voltage drop across the USR leds, its 5V :frowning:
Thanks for the response.