BBB doesn't seem to boot from SD Card. Only 4GB storage available

Long time Pi user trying to start up on a BBB.
Downloaded latest Debian image. Wrote it onto my 8GB MicroSD card using Balena
I insert the SD Card, then plug USB cable in to power up the BBB while holding Boot button.
On boot, when I do df command, there’s only 4GB visible…which makes me think I’m not booted from the SD card. I’ve tried on two BBB’s, with the exact same result.

When I do fdisk I can see two devices /dev/mmcblk0 (with 7.4GB) and /dev/mmcblk1 (with 3.6GB)

If I do df to see how much disk space I have, it shows me /dev/mmcblk0p1 3558936 2146928 1211512 64% /

Which is only 3.6 GB

But when I do cfdisk on the same mmcblk0 device, it shows me a 7.4GB partition. That’s bootable.

I’ve read the previous articles, but many are quite old and I’m just trying to install the plain vanilla Debian image.

I can install software, ssh in to the BBB, access the network. Just that I only seem to have 4GB storage and I know it won’t be enough for my use.

Ehm…am I doing something silly?


Which image exactly? Older images required you to ‘resize’…

cd /opt/scripts/tools/
git pull || true
sudo ./
sudo reboot

Where-as newer snapshots (Bullesye) do it after the first reboot… (or ones without the /opt/scripts/tools/ directory) automatically…


But yes - that solved it.

I had tried to check the partition sizing with cfdisk, but clearly did something wrong.



I used the third one down on the “latest images” page.

AM3358 Debian 10.3 2020-04-06 4GB SD IoT