BBB immediately fails when trying SSH

Trying to log in to my BBB using SSH, getting error:

debian@ Permission denied (publickey,password)

When to /etc/ssh/sshd_config and changes to not accept RSA or pubkey, and now I get

debian@ Permission denied (password)

The main issue is that I never get asked my password, it immediately fails, I have also tried on my client to do the ssh-copy-id but same error pops so the key never gets copied, how can I configure the ssh to work?

Tried also to use the following configuration:

PasswordAuthentication yes
ChallengeResponseAuthentication yes

My beagle board version is:

Linux beaglebone 3.8.13-bone79 #1 SMP Tue Oct 13 20:44:55 UTC 2015 armv7l GNU/Linux

I know its old but I need this image because it contains some libraries I need for school, because SSH is linux based I think I can fix it?

Also, VNC Viewer does work so SSH does work but I cannot login

Have you done this on the BBB?

$systemctl status ssh.service

If that shows active don’t bother to install it.

$ sudo apt install openssh-server

Can you post a screen shot of the entire transaction?

Says the following:

root@beaglebone:~# systemctl status ssh.service
ssh.service - LSB: OpenBSD Secure Shell server
          Loaded: loaded (/etc/init.d/ssh)
          Active: active (exited) since Thu, 12 Nov 2015 19:02:25 +0000; 7 years and 1 months ago
         Process: 519 ExecStart=/etc/init.d/ssh start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/ssh.service

Nov 12 19:02:25 beaglebone ssh[519]: Starting OpenBSD Secure Shell server:
Nov 12 19:02:25 beaglebone ssh[519]: /etc/ssh/sshd_config: terminating, 1 b...ns

I tried connecting with -vvv and got the following logs

debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred publickey
debug3: authmethod_lookup publickey
debug3: remaining preferred:
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /Users/dariovazquez/.ssh/beaglebone_rsa RSA SHA256:G0QXpX5sqZ/mLf+dcdbWjLXVHVUDDz4nmn92gpTyXYk explicit
debug1: send_pubkey_test: no mutual signature algorithm
debug1: Offering public key: /Users/dariovazquez/.ssh/d_vazquezherrera RSA SHA256:jxXSCOPhVeM6CcKmLoqjGiGMm3L4nMN/qOySHgPYcRI explicit
debug1: send_pubkey_test: no mutual signature algorithm
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
debian@ Permission denied (publickey,password).

Do you have a TTL to USB adapter so you can get into the target and see what is going on. If you are locked out of SSH access your only option is to use the linux debug port. This also assumes you have user and password for the board.

Myself, if it cannot be solved in 15 minutes or less I just flash a fresh OS and git clone my work onto the fresh OS and reinstall a few packages.

If you create a bash script of all your installations just keep it in the directory you send up to your private git server. When you clone onto the new board just git clone and run the script and you will be back up.

This is also where git becomes your best friend.

I just realized you are on the target from root@beaglebone.

Assuming from the debug no mutual signature algorithm might mean that what you have established is not compatible with each other.

What is your actual ssh command line. You have debian and root in your examples.

On target and host


overwrite existing keys and try it again

on the target

$ip route

Update later today.

Just tried to replicate what you are doing using a Pocket Beagle.

What I have discovered so far it will not work with Debian 11 or Ubuntu Jammy in a VMware workstation 17 on a amd64 Jammy host.

ssh does work perfectly with native Deb 11 and Jammy.

$ssh debian@

So if you are using a VM that might be an issue.

The USB drive does connect and the start.htm file can be opened while on either OS using a VM, the networking does not work. Have not tried this with virtualbox or VMware player.


It does work in VMware.
Running multiple VM’s at the same time with a dual ethernet card created my issue with getting it all configured properly.

My suggestion would be to use only 1 vm at a time to make life simple or just run native.