BBB not booting either from eMMC or SD Card

Hi All, I need your help in getting my BBB rev c back to life.
Issue 1: BBB when connected to windows PC through micro USB, it is not showing up as mass storage in PC
Issue 2: When tried to boot from SD card, by pressing S2 switch and powering the board, all user LEDs turn ON always after that nothing happens (S2 was kept pressed for variable time period).
Issue 3: Simply powering ON board is also not working as I see no activity in teraterm screen connected to J1 header of board.
Issue 4: SD card slot 2 pins were bent but that has been “fixed” (I think). BBB uses Molex 502570-001 sd card connector which I think not available now a days (Any alternative??)

I have tried many images from from 2013, 2015 2016, 2018 and latest images. eMMC flasher images as well as sd card only images both I have tried with no success. Please help me to fix this issue, thank you very much in advance.
I dont have any logs as my board not spitting out any logs.

The PCB had to be redesigned, as these are all gone…

Best thing is always j1 usb-serial log…


I have connected J1 serial ftdi cable there I’m getting CCCCCCCC… as output

Okay therefore the eMMC is blank, and the microSD wasn’t detected… If the microSD was plugged in, you could try holding down the ‘usr’ button and resetting hte board, but if all you get is CCC's then the bootrom is not finding a valid MLO on the microSD…


How do I make bootrom find valid MLO?
Because I’m just flashing sd card with different images hoping one would work. Is there a definite way to fix this or make it work? Thanks

Grab the am335x minimal image from here: Debian 12.x (Bookworm) - Monthly Snapshot - 2023-10-07 Use to write it to a microSD…

If your microSD is good, cage good, it’ll boot…

also try other microSD’s…


Hi Robert,
I have followed what you said and flashed minimal image both for micro SD Card and eMMC but still same issue. When powered on board after plugging in sd card and pressing and holding Boot button all user leds are turning on and thats it nothing happens after that. output on teraterm screen is just 6-7 C’s. I also changed micro sd card.
Please let me know how could I fix this issue. Another question I have is can I replace sd card connector which is on board