BBB not booting from sd-card

Dear all,
I have obtained the latest debian image from the official site. I unpack the file and flash the .img to my SDCARD. I hold the boot button and insert my 5V,2A in. The beaglebone does not seem to start, only the power LED glows,USR0-3 do not glow. I cannot boot from the SD Card.

Let us consider another case.
The SD card is in, I just plug in my 5V 2A cable and the power led glows. Shouldn’t the BBB boot from the eMMC. But that does not happen. Again the led’s does not glow. How can I debug this?

Remove the SD card.
Plug in power.
It should boot from the eMMC.

Gerald

Yes, It does boot from the eMMC. The point of the post is that I want to boot from the sdcard and later flash my image onto the eMMC.

I understand the point of the post. I was trying to help make sure that it could boot from the eMMC and that it was not corrupted as a response to the second part of your post.

Let us consider another case.
The SD card is in, I just plug in my 5V 2A cable and the power led glows. Shouldn’t the BBB boot from the eMMC. But that does not happen. Again the led’s does not glow. How can I debug this?

That was the reason for my post. The SD card can prevent it from booting form the SD card.

Sorry if I missed your point of the post.

Gerald

Yes Mr.Gerald, I can boot from the eMMC and ssh into it. I just can’t get it boot from the SD card. Thank you much for your help Mr.Gerald. If you could suggest any way that I can flash the eMMC directly with debian ?

It is on the site you refereed to in your first post.

For testing, flasher and other Debian images, see http://elinux.org/Beagleboard:BeagleBoneBlack_Debian

Gerald

The site gives instructions on a debian distro. I am running Angstrom I
cannot seem to find the script on my beaglebone at all.

Flashing eMMC

To setup the standalone microSD image to automatically flash the eMMC on
powerup.

In /boot/uEnv.txt:

##enable BBB: eMMC Flasher:
#cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

Change to:

##enable BBB: eMMC Flasher:
cmdline=init=/opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh

OK. Debian is the official release we support. I suggest that you contact the Angstrom support team.

Gerald

https://github.com/beagleboard/meta-beagleboard

Commits on Sep 5, 2013

Good luck!!! your on your own!!

Regards,

I found the solution. Beaglebone Black does not recognize FAT. Your SD card must be formatted at FAT 32. Thank you for your help Robert and Gerald.

Glad you found.

Gerlad