BBB not Flashing the eMMC

New to the world of BBB and bought one and am stuck at flashing the eMMC on the BBB.

I followed the instructions on the BBB website, but the thing just won’t flash - I’m sure it’s something I’m not doing right, but it seems dozens/hundreds/thousands of similar folks have the same exact problem.

Here is what I did as per the manufacturer’s instructions: (

  1. Connected the BBB to PC running Windows 8.1 with mini-USB cable
  2. Installed 64-bit Windows drivers - restarted Windows and resumed this process
  3. Used Windows Chrome to browse to BBB at - everything looked fine
  4. Updated BBB to latest software:
    a) downloaded latest BBB image at:
    b) downloaded and installed 7Zip and unzipped the .img.xz file to just a .img file
    c) downloaded and installed the Image Writer for Windows and it built the 16 GB SD micro flash - I looked at the directory and it seems just fine with all the files having today’s date
    d) unplugged BBB and inserted the SD
    e) Pressed and held the Reset button on the BBB while inserting the 5V 2A power cord - held button down 5 seconds and all 4 LEDs lit up
    f) LEDs flashing for about 1 minute then just LED 0 flashing the heartbeat for the next 5 hours - no 4 lit LEDs as the instructions promise.

If I connect the Mini USB I can see the SD card directory, with all files having today’s date, which means BBB booted from the card but when I remove the SD card and reset BBB I see the original 2013 files that were never flashed on the eMMC

I’m missing the step where the booted SD flashes it’s image to the eMMC and I can’t find documentation that helps.
I guess I could delete the eMMC and copy over an image of the SD but I doubt that would work.

So what the heck am I doing wrong?

Thanks for any help…this really should not be this hard for hundreds/thousands of users having the same exact problem…

I just went through this same thing a couple days ago. From what I can tell (and others, please correct me if I’m wrong), there are two different types of images. One just runs off the SD card (which I am guessing is what you are using); the other is configured to actually flash the image onto the eMMC. I’d been trying the non-flasher image, and was seeing the same thing you are. What I did was to go to and about 2/3 of the way down the page is a Debian flasher image under the title of

“BBB Rev C (4GB eMMC) 4GB eMMC Flasher” with an acual file name of:


Once I downloaded that image, unzipped it, and installed it on my SD card, the flash instructions worked marvelously to flash the image onto the eMMC of my BBB rev C.

Hope this helps!


Hi Scott,
I too had experienced the same issue and tried your remedy by using this flasher version. But now it seems the Beaglebone black can’t boot without the SD card. Did you experience something like this also?
The scenario is something like this -
When I insert the SD card and power it on using the USB the LEDs work normally but the SD card inside cannot be detected by Windows 7. However earlier the eMMC/SD card appeared like an external card inserted via USB.