BBB not mounting when plugged in via USB (Windows 8)

Hello all,

I'm having a pretty big issue. Before, I was able to connect to my computer via USB just fine. A couple days ago, I attached a cape and assembled a small robot kit around it. I ran some example programs on the cape a couple times at different times of the day. Unfortunately, when I got home to show it off to my family, it no longer wanted to connect - randomly.

Now it's been a couple of days and still won't connect. I have been trying to get it to work again, but to no avail. All the proper lights are blinking, so I believe it's turning on fine when I plug it in. Windows even makes the noise like its connecting and disconnecting. But whereas my File Explorer would pop up when I connected it, it no longer appears. It just doesn't want to mount.

I tried resetting my computer, resetting the beagleboard, and tried a different USB cable and port. I tried asking my friends and searched around. I find very little cases like mine, and they all see seem to manage to get it to work using different solutions. None of which work for me.

Per suggestion elsewhere, I ran a utility that allows me to look at the USB ports. The one on top is with the BBB unconnected, bottom is connected. It seems there is no difference.