BBB ping not working after restart

Dear all,

I am having a strange problem with my BBB, I could not find any solution so far on internet to solve the issue so writing here.

I have configured my BBB with stable debian image from the main BB website. After that I did the internet configuration

added default gateway and updated nameserver
then the ntp for date

internet worked. I updated/upgraded and then I updated the kernel to have source headers as I needed them for some driver I wanted to install. I followed the following instructions provided by Robert Nelson;!topic/beagleboard/l5RLNUGYrAc

chmod +x

The kernel was successfully updated and I moved forward with my work happily. Today, when I came back to work and started my BBB ran the script I used to update the gateway and namerserver on startup. After that I did ping, it did not work.

It just stays there no response at all, I assume that it is sending the packets but not receiving back any. I don’t know why I am having this problem. Any help will be highly appreciated. Please let me know if any help is required.

PS: I am running windows 7 PC, which is connected to a wireless network.


I have solved the problem. The solution is quite strange but worked for me so I thought I should share if anybody will have the same problem in future.

All I did is that in my windows pc I re shared the internet connection.