BBB power led blinking, revived after several power button presses

Just had a 5V powered Beaglebone Black seemingly die on me. First the power led kept blinking, then after removing the (BB Toys CAN) cape the power led would flash just once after applying power. Looking back in previous threads this seemed to mean I killed the board somehow; there was also a GPS module attached to one of the UARTs and a probably power hungry USB wlan stick that I’m trying to get to work, so a power hungry setup.

I was ready to declare it dead, it remained just flashing once after repeatedly unplugging and reattaching the power supply.

However I noticed the single power led flash would also happen if I pressed the power button (leaving the 5V plug in). Doing that repeatedly seems to have revived the board, will see if new problems occur. For now it behaves normally.

Is this expected behaviour?

Best,

-Bert

This is not expected behavior. Although, it may be explained once it is understood as to what is going on…

Gerald

Hard to say really. It first happened during a reboot, I think, and a milder version since happened at another reboot. Maybe it’s temperature related and it needed cooling down a bit that first time?

Possibly. But I am at a loss to say where. We need a way to consistently duplicate this so we can take a look.

Gerald

Last ditch: connect 3.7V (or similar) to the battery pins (TP6 3.7V, TP8 gnd), and see if it boots up. My 5V 1.2A switching PS can barely handle my board, but the battery is good enough to handle the bursts without driving the P/S into over-current protection (cutoff). My Li-Po has managed to stay at 3.9V after being plugged in for a while.

Gerald, I think it’s simply broken - even the bare BBB without any capes or USB devices will refuse to operate immediately after power now, just one short power led blink after application of power or power button (very reliably, it pretty much always happens). If I keep pressing the power button often enough at one point it will come to life and boot normally. I don’t know how I managed to break it - is having a too power hungry setup enough?

Best, -Bert

I suggest you request an RMA.

http://www.elinux.org/Beagleboard:BeagleBoneBlack#RMA_Support

Gerald

ok thanks.

Very interesting thread, as this is exactly what has happened to me…with TWO RevC units now. The first unit died about 6 weeks ago, while just sitting on a wooden desk, powered by an external 5v power supply purchased (as was the BBB) from Adafruit. So I ordered another unit from Adafruit, received it and have been using it. I was working out of Derek Molloy’s new book last night, and connected an ADXL345 accelerometer via a very simple I2C circuit, and the thing

was working. However after 4-5 minutes it powered down, and now will not power up again. And the kicker is that I then connected the exact same circuit to my Beaglebone White unit, and it works perfectly–and continues to do so. I’ve connected countless circuits to the BBW unit without incident–so it makes me wonder where I’m going wrong with the BBB? RMA requests have been submitted for both units, so at the very least maybe I can get some feedback as to what the problem(s) might be.

TB

I had a similar problem- my power LED would just continue blinking when connected to a 5V power source. This meant there was something wrong. First, I checked if my BBB was still alive. To find that, I connected my board to a computer via USB. Surprisingly, this time power LED turned on normally. Then to make sure that everything was properly, I ran some program as given in the BB website http://beagleboard.org/getting-started. I was happy to see, the programs on the website worked just fine on my board. Thus, I was able to conclude that strangely, my BBB board didn’t like 5V external power source!

http://beagleboard.org/getting-started. I was happy to see, the
programs on the website worked just fine on my board. Thus, I was able
to conclude that strangely, my BBB board didn't like 5V external power
source!

The BeagleBone Black & BlueSteel Basic seem to be extremely sensitive to the rise time of the 5V power supply at startup.

1 ms or longer is a problem, and it is not at all unusual for power supply to be slower than this.

200 us is reliable.

See also:
https://groups.google.com/forum/#!msg/beagleboard/aXv6An1xfqI/Vy9JxPRvIPwJ

The original BeagleBone White, for whatever reason, did not have this issue. (Anyone know why?)

I feed my raw power in through a voltage-controlled solid state relay circuit, and I get 100% reliable startups now.

- Mike

Hi, there,

I also have the power problem in my two Beaglebone black, Rev C. One of my BBB totally die out and no any led turn on when the power was plugged in no matter from usb or DC jack. The other one just have the power led flashing once.

I have disabled the HDMI in Env.txt and use six pins for receiving three DC motor decoder signals, use three pins to output PWM signal and three pins for direction control for three DC motor.

So far, I still couldn’t find the reasons that make them broke even I carefully read the user manual. I also use flyport with pic24 for flying control for more than one year and that board is very stable and never give me any headache.

The BBB designer or manufacturer should came out to give us a good explanation because so many people have same power problem.

Best Regards,
Chi-Wei Wu

Identical problem this morning: BBB boots fine when powered by USB, but not when powered by a 2.0 mA rated 5.0 V DC power supply (nicked from some other device). BBB power LED blinks continuously. This power supply has worked with this BBB in the past.

Mike.

I have seen this before. The USB path and 5VDC paths are different through the PMIC. It is possible that the PMIC has sustained some damage or it could be the 5VDC power supply is not powering up properly, where it has a voltage spike, causing the PMIC to shutdown.

Past performance of power supplies is no guarantee of future performance. It could be right on the edge.

Gerald

Thx. Will try another PS if I can find one. Otherwise will have to stick with USB for now. M.

My Rev C BBB purchased from Adafruit just died on my in the exact same way. I can’t get it to boot at all whether connected to USB or 5V power supply.

Have you tried booting from an SD card?

I suggest you switch to a \different power supply. A good one.

http://www.elinux.org/Beagleboard:BeagleBoneBlack#Improper_Power_Down…All_Revisions

Gerald

The power supply I bought is from AdaFruit, which I expected to be well suited to my BBB.

I haven’t yet tried booting from an SD card, so I’ll do that this evening.

I tried booting from an SD Card and got nothing. I tried a different power supply, and it won’t boot.

Really not happy with the BBB as I’ve only used it a handful of times. It died after I pressed the Reboot button, which I now know can cause it issues.

I think I’ll buy the RPi2 and not mess around with BeagleBone anymore.