[BBB] Power light on but no USR light activity


I am just started using my BeagleBone Black mcu and have minimal idea what I am doing. I was trying to install the newest Debian9 on the board (the image was from the BBB website)

I am sure I followed the instructions accurately. Upon completion of the flashing, I removed the SD card and then booted. Initially lights turned on but now, nothing happens.

Current state of the board :

  • power light glows , the USR lights do not turn on.

  • Powering on with holding down the user boot button does nothing.

  • I have tried holding the button down for 2 minutes but the USR lights do not turn on.- Tried connecting the network cable to board.

  • Board does not show up in the list of connected devices on the router (board is not assigned an IP address)

  • When board is connected to the desktop

  • Sometimes board shows up as AM335x

  • Sometimes it shows up as unable to retrieve device identification

  • Unable to install BeagleBone driver because of win10 restrictions. Windows does not let me install the drivers. Tried looking all over the internet. No success

  • The device used to work under Ubuntu linux Vmware virtual machine.- Tried powering with DC power supply. Same results

I don’t know how to proceed. Connecting with serial port listener (hype! software) under win10 gives error. Unable to connect the device to Ubuntu. Vmware gives error when trying to connect. Something about driver not correct. I didn’t need driver when the board was working fine to connect to virtual machine.

Any help would be appreciated. I am a complete novice with this board.

If you go to

And download the appropriate image for your board,
then install it on a microSD card using Etcher, without any changes.

Then boot the BBB without removing the card, does the BBB run as expected?

In other words, will the BBB run from the image on the microSD card?

— Graham