[bbb] problem with sd card

hi i have a problem with beagle bone, yesterday i downloaded https://debian.beagleboard.org/images/bone-debian-10.3-iot-armhf-2020-04-06-4gb.img.xz on the sd card, i inserted in beagle because I wanted to unload the kernel, when it read the user leds they lit up and turned off correctly, then it went off, so far everything was fine.
then I tried to connect to beagle with ssh but I was no longer able to access, also the leds remain all 4 on, what can I do …
thank you

Hi @Simone_Dallai what do you see on the j1 (serial debug) port?



no i’m not looking at that site, but i wanted to know why i can’t access with the ssh ethernet and why all 4 leds remain on, i don’t know and need to reboot or do i try to connect with the serial?

All “4” led’s on is usually an error or lockup condition…

To know more… we’d need to see what error message was spawned over J1…


hi I solved the problem the sd card must be inserted in beagle otherwise it gives me that error, but now is there a tutorial where you can download the linux kernel and linux header? thank you

2 ways, built-in kheaders or linux-headers-uname -r


modprobe kheaders
rm -rf $HOME/headers
mkdir -p $HOME/headers
tar -xvf /sys/kernel/kheaders.tar.xz -C $HOME/headers >/dev/null
cd my-kernel-module
make -C $HOME/headers M=$(pwd) modules
rmmod kheaders

or old way…

sudo apt install linux-headers-`uname -r`


do i have to download something from the internet? Or should I just follow these instructions?

that’s “pre-installed” in your image… (well depending on how new it is…)

That will require network access…